Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    RPM Dependancy problem

    So I find myself installing SipXpbx for my company on a fedora Core 3 system. While running the install script, it repeatedly gives me the error that is needed to install some if the programs rpm's. At, the lates version of libstdc++ is older than what's on the system <I downloaded it and tried to install it. That's what it notified me of>. The sipx program was built for fc2. Am I just out of luck on fc3 or is there something I can do? I've already tried to install the packages using the --nodeps switch.

  2. #2
    Am I in the wrong forum listing for this problem? Should I be in the OS category, or is this the right place?

  3. #3
    THIS ISSUE IS RESOLVED. Here's the resolution for anyone out there. I found someone else that had the same issue installing another piece of software. Thank to everyone that looked it over for me!

    The following message may appear if installing BitDefender on a Fedora Core 3 system.
    error: Failed dependencies: is needed by BitDefender-core-1.6.1-0.i586 is needed by BitDefender-core-1.6.1-0.i586 is needed by BitDefender-core-1.6.1-0.i586

    Could not complete the installation of the .rpm. package, aborting installation.

    Fedora Core 3 has gcc 3.4 that provides while BitDefender requires another version of this library, In order to satisfy this dependency, the compat-libstdc++ package must be installed. (you can find it on the distribution CDs)

    This package is required not only by BitDefender but also by other officiall Fedora Core 3 packages.

    Afterwards retry the BitDefender installation process.

  4. $spacer_open
  5. #4
    Thanks for the solution...I had a buddy run into that loop the other day when he was installing something else and I didn't have time to help him (then I forgot about it until I saw your post). Now I can tell him what to do.

    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  6. #5
    Just Joined!
    Join Date
    Mar 2005
    Austin Texas
    Thank you for the post

    This solved a problem on Fedora Core 3 i386 where mysql-administrator would not run.

    I appreciate the help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts