Find the answer to your Linux question:
Results 1 to 5 of 5
In Windows, I'm used to clicking down on the scroll wheel with my Microsoft Intellimouse Optical, on a tab to close it. In Linux (SimplyMEPIS 3.3), Firefox does some unusual ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    11

    Firefox middle mouse button (scroll wheel click) problem


    In Windows, I'm used to clicking down on the scroll wheel with my Microsoft Intellimouse Optical, on a tab to close it.

    In Linux (SimplyMEPIS 3.3), Firefox does some unusual **** (usually loads a page like the Pine home page for example -- I don't know how or why its picking these pages, they seem random!) instead of closing the tabs.

    Am I the only one with this problem? I had the same problem with the last distribution release of MEPIS too...

    Thanks
    - Tharsan

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Posts
    11
    I've been able to determine that Firefox is actually searching for the term currently in the clipboard, and displaying a page based on that.

    For example, if I copy the term 'Linux' into my clipboard, then attempt to close a tab by wheel-clicking on it, The Linux Home Page at Linux Online (www.linux.org) shows up.
    As soon as I do the wheel-click, I also see 'Looking up linux...' in my status bar, before the page loads.

    I'm completely confused...

    Thanks
    - Tharsan

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    11
    Figured this one out:

    Type 'about:config' into the address bar, and change the value for 'middlemouse.loadContentURL' to false.

    Thanks anyway =)

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666

    Re: Firefox middle mouse button (scroll wheel click) problem

    Quote Originally Posted by tharsan
    In Windows, I'm used to clicking down on the scroll wheel with my Microsoft Intellimouse Optical, on a tab to close it.

    In Linux (SimplyMEPIS 3.3), Firefox does some unusual **** (usually loads a page like the Pine home page for example -- I don't know how or why its picking these pages, they seem random!) instead of closing the tabs.
    hehe.... that had me going nuts for weeks also... but in firefox it is whatever you last cp'd and then you click in the feild of the window and you will goto a page accicioted with whatever was last highlighted(cp'd).....that is whtat is happening

    (if a url was cp'd then it will go to that url if a word was cp'd then it will goto a search then the top item is where u will go) that is what is bound with key bindings to the middle button in firefox...
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  6. #5
    Just Joined!
    Join Date
    Nov 2010
    Posts
    1
    Or, you could just go into Edit>Preferences, Advanced tab, and check the box that says "Use autoscrolling".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •