Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, i posted this in the slackware forum and then realised its probs best of here, sorry all. Im having trouble running firestarter. If I run it as a user, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    68

    Firestarter help (user needs root privs, root needs display)


    Hello, i posted this in the slackware forum and then realised its probs best of here, sorry all.

    Im having trouble running firestarter.

    If I run it as a user, it says I need root privlidges, if i run it as root I get:

    Code:
    (firestarter:3587): Gtk-WARNING **: cannot open display:
    I have tried:

    Code:
    xhost +localhost
    but, as root, get:
    Code:
    (firestarter:3603): Gtk-WARNING **: cannot open display:
    Is it possible to change which users have the rights to run an app? I have tried chmod 777. If not how can I add root to the display owners?

    Thanks much?

    <edit> if i "su root", i can run it but really dont wont to be doing this at all.

    Thanks again.

  2. #2
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    In a regular distro, I would copy the init script to /etc/init.d and place it in the proper runlevel folder (rc*.d) so that it would run as a service at boot, instead of manually being started by a user. However, if I remember correctly, Slack uses the BSD-style init scripts...I haven't used Slack in a while, so I can't help much with telling you how to set that part up.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •