Find the answer to your Linux question:
Results 1 to 10 of 10
I tried to install a program needing gtk v1.2, and apparently gtk wasn't installed, so I'm trying to install it. I've downloaded the tar's, gtk+-1.2.9.tar.gz and glib-1.2.9.tar.gz. I installed glib ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2003
    Posts
    5

    Problems installing gtk


    I tried to install a program needing gtk v1.2, and apparently gtk wasn't installed, so I'm trying to install it.

    I've downloaded the tar's, gtk+-1.2.9.tar.gz and glib-1.2.9.tar.gz. I installed glib first since gtk wouldn't install without it, now glib is installed, I get this error from the ./configure script of gtk and have no idea where to go.
    checking for GLIB - version >= 1.2.8...
    *** 'glib-config --version' returned 1.2.9, but GLIB (1.2.10)
    *** was found! If glib-config was correct, then it is best
    *** to remove the old version of GLIB. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If glib-config was wrong, set the environment variable GLIB_CONFIG
    *** to point to the correct copy of glib-config, and remove the file config.cache
    *** before re-running configure
    no
    configure: error:
    *** GLIB 1.2.8 or better is required. The latest version of GLIB
    *** is always available from ftp://ftp.gtk.org/.
    The system is RedHat 9.0 with all patches applied, and running KDE.

    Any and all help appreciated!

    P.S. My first post from Linux!

  2. #2
    Linux User
    Join Date
    Jun 2003
    Location
    Calgary, AB CANADA
    Posts
    496
    Issue the following:
    Code:
    rpm -qa glib*
    and see if your glib-1.2.9 took effect...
    \"Everything should be made as simple as possible, but not simpler.\"
    Albert Einstein

  3. #3
    Linux User
    Join Date
    Nov 2002
    Posts
    420
    Thanks Copper, I get...
    $ rpm -qa glib*
    glib-1.2.10-10
    glibc-devel-2.3.2-27.9
    glib2-2.2.1-1
    glibc-kernheaders-2.4-8.10
    glibc-2.3.2-27.9
    glibc-common-2.3.2-27.9
    So it seems 1.2.9 didn't take effect, but then I did install it from a .tar.gz so would rpm still find it?

    ....but if glib 1.2.10 was already installed, why did the gtk install complain at the beginning? and how do I uninstall what the glib 1.2.9 tar.gz has done, and perhaps start a fresh. :\ If that's where I should go next?

  4. #4
    Just Joined!
    Join Date
    Jun 2003
    Posts
    5
    Erm, that's me. ^^ How odd.

  5. #5
    Linux User
    Join Date
    Jun 2003
    Location
    Calgary, AB CANADA
    Posts
    496
    You must have forgot to sign in there...

    Anyway, re-reaqding your original post, it says that it did find 1.2.10 and then makes some suggestions to remedy the problem. Since your glib-config is incorect (states 1.2.9 but find 1.2.10), then I would try the last part:
    Code:
    *** If glib-config was wrong, set the environment variable GLIB_CONFIG 
    *** to point to the correct copy of glib-config, and remove the file config.cache 
    *** before re-running configure
    Let us know what happens and g/l!
    \"Everything should be made as simple as possible, but not simpler.\"
    Albert Einstein

  6. #6
    Just Joined!
    Join Date
    Jun 2003
    Posts
    5
    Okay, sorry, but where would I find / set environment variables?

  7. #7
    Linux User
    Join Date
    Jun 2003
    Location
    Calgary, AB CANADA
    Posts
    496
    Something like this:

    Code:
    GLIB_CONFIG=/usr/bin/glib-config; export GLIB_CONFIG
    N.B. The semi colon means you're running two commands on one line.
    \"Everything should be made as simple as possible, but not simpler.\"
    Albert Einstein

  8. #8
    Just Joined!
    Join Date
    Jun 2003
    Posts
    5
    Thanks, I did that but it made no difference.

    I did echo '$GLIB_CONFIG' to prove it worked, then re-ran the gtk ./configure but it still died with the same error message.

    I seem to have 1.2.10 installed (by rpm) and 1.2.9 installed (from tar.gz) thus the conflict.

    I tried 'rpm -e glib', but I can't remove the 1.2.10 version due to dependencies it says. So I should try and remove 1.2.9? but I have no idea what files, and where, ./configure, make, make install, put them.

    Edit/PS: Although I seem to have 2 versions installed, I only have one glib-config.
    $ whereis glib-config
    glib-config: /usr/local/bin/glib-config
    ..and that's the location I put in the GLIB_CONFIG variable.

  9. #9
    Linux User
    Join Date
    Jun 2003
    Location
    Calgary, AB CANADA
    Posts
    496
    Did you try removing the config.cache file before reconfiguring?

    And I think you'll have a hard time trying to remove glib because of it's heavy dependencies. Let's try first to get your glib version correctly recognized...
    \"Everything should be made as simple as possible, but not simpler.\"
    Albert Einstein

  10. #10
    Just Joined!
    Join Date
    Jun 2003
    Posts
    5
    Okay.

    Yeah I did a search for config.cache and never found it.

    [Edit] I've managed to uninstall 1.2.9, and am back at square one. I have to go out, but will tackle it again when I get back.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •