Find the answer to your Linux question:
Results 1 to 8 of 8
Dear All, I am using SUSE 9.1 Pro version, and I need to install gtk+ 2.6.4. I have downloaded all glib.2.6.3, atk-1.9.0, pango 1.8.1, gtk+-1.6.4 from ftp://ftp.gtk.org/pub/gtk/v2.6/ . I have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    1

    Installing gtk+ 2.6.4: Error


    Dear All,

    I am using SUSE 9.1 Pro version, and I need to install gtk+ 2.6.4. I have
    downloaded all glib.2.6.3, atk-1.9.0, pango 1.8.1, gtk+-1.6.4 from
    ftp://ftp.gtk.org/pub/gtk/v2.6/. I have installed glib.2.6.3. When I try to
    install atk, I am getting the following error (although running ./configure
    does not give any error);

    make all-recursive
    make[1]: Entering directory /home/yildirim/downloads/atk-1.9.0/atk-1.9.0'
    Making all in atk
    make[2]: Entering directory
    /home/yildirim/downloads/atk-1.9.0/atk-1.9.0/atk'
    glib-genmarshal --prefix=atk_marshal ./atkmarshal.list --header >> xgen-gmh
    \
    && (cmp -s xgen-gmh atkmarshal.h || cp xgen-gmh atkmarshal.h) \
    && rm -f xgen-gmh xgen-gmh~ \
    && echo timestamp > stamp-atkmarshal.h
    /bin/sh: line 1: glib-genmarshal: command not found
    make[2]: *** [stamp-atkmarshal.h] Error 127
    make[2]: Leaving directory /home/yildirim/downloads/atk-1.9.0/atk-1.9.0/atk'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory /home/yildirim/downloads/atk-1.9.0/atk-1.9.0'
    make: *** [all] Error 2

    When I try to install pango 1.8.1, I am getting the following error
    (although ./configure does not give any error message)

    make all-recursive
    make[1]: Entering directory /home/yildirim/downloads/atk-1.9.0/atk-1.9.0'
    Making all in atk
    make[2]: Entering directory
    /home/yildirim/downloads/atk-1.9.0/atk-1.9.0/atk'
    glib-genmarshal --prefix=atk_marshal ./atkmarshal.list --header >> xgen-gmh
    \
    && (cmp -s xgen-gmh atkmarshal.h || cp xgen-gmh atkmarshal.h) \
    && rm -f xgen-gmh xgen-gmh~ \
    && echo timestamp > stamp-atkmarshal.h
    /bin/sh: line 1: glib-genmarshal: command not found
    make[2]: *** [stamp-atkmarshal.h] Error 127
    make[2]: Leaving directory /home/yildirim/downloads/atk-1.9.0/atk-1.9.0/atk'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory /home/yildirim/downloads/atk-1.9.0/atk-1.9.0'
    make: *** [all] Error 2

    And because gtk+-2.6.4 needs these libraries, I cannot install it. It will
    give the following configuration error:

    checking for pkg-config... /usr/bin/pkg-config
    checking for glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0...
    Requested 'pango >= 1.8.0' but version of Pango is 1.2.5

    configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1
    pango >= 1.8.0) not met; consider adjusting the PKG_CONFIG_PATH environment
    variable if your libraries are in a nonstandard prefix so pkg-config can
    find them.

    Can someone help me how to solve this problem? Thanks in advance.

  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    I would leave out the 'all-recursive' and just do:
    Code:
    ./configure
    make
    make install

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Location
    Indonesia
    Posts
    2
    maybe your need use this line to configure your program


    ./configure --prefix=/usr

    so your program is installed in the /usr directory because the default prefix for the source code installation is /usr/local and the pkg-config is searching in the /usr directory

  4. #4
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    Is the glib-genmarshal program in your path? Was it even installed? Might need to check the glib installation.

  5. #5
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2
    this problem look almost exactly the same as mine. I'm running suse 9.2 and trying to compile gnome 2.10 (as the final result).

    i had a problem with this on my laptop so i installed on my desktop to try it there, but glib doesn't seem to be adding those executables. I get no errors on install of glib, make check is all good, and the md5sum is correct.

    Is there somewhere i can just manually download the files and insert them into my path manually or is there something i'm missing?

  6. #6
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2
    the files were sitting in the directory gobject of where i extracted the archive. by copying the files into /usr/bin/ everything worked fine

  7. #7
    Just Joined!
    Join Date
    Jan 2005
    Location
    Here!
    Posts
    18
    Well, it seems you are not the only ones that have a problem:

    I have downloaded atk-1.9.0, glib-2.6.3, pkgconfig-0.15.0, gtk+-2.6.4 and pango-1.8.1, and installed every single one of the by doing

    ./configure
    make
    make check
    sudo make install


    on each folder, except the gtk+-2.6.4 one.

    So, now, I get to that one, I do the same, and I get the following error when I do ./configure:

    checking for pkg-config... /usr/local/bin/pkg-config
    checking for glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0... Package atk was not found in the pkg-config search path.
    Perhaps you should add the directory containing `atk.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'atk' found

    configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.


    I don't have to say that in every previous install I didn't get any errors, and I have tried to do make clear and make uninstall in each of the folders and try again, but without any results.

    I have Knoppix 3.7 installed (based on Debian) and I am desperate, cause a plugin for XMMS that plays wma and wmv needs gtk, and I have lots of wma/wmv files.


    any help would be, well, helpful... :P


    thank again,


    - ardeth

  8. #8
    Just Joined!
    Join Date
    Apr 2005
    Posts
    1
    Ok, I found a solution. I'm a complete noob to Linux, but obviously my continues selfopinionated testing turns out to work after al, lol.

    You have to uninstall the old version of GTK:

    Open Konsole (Or Console, dependent on whether you've got KDE or nor)

    Type su, then type the root password

    go to /usr/local/lib

    run the following command: libtools --mode=uninstall glib[versionnumer]

    after this is completed you should be able to make ATK

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •