Find the answer to your Linux question:
Results 1 to 10 of 10
Ok, here's the deal.... All of these things work localy. I can login to each just fine. I run dns software to keep track of my ip, and that works, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2003
    Posts
    28

    Telnet,Ftp,Web page..... No workie


    Ok, here's the deal....

    All of these things work localy. I can login to each just fine. I run dns software to keep track of my ip, and that works, as i also run a game server and people connect to it just fine. I also setup exim and i can create and send mail from this domain. So it's not a name/ip issue.

    When people try the web page it gets:

    People Cannot connect to telnet or FTP either... Yet it all works localy....

    I have turned off Iptables....running redhat 9

    Any help would be appreciated. And as you can see, i can also host images just fine..

  2. #2
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    hosts.allow / hosts.deny in /etc/ ?

    are they actually getting a TCP RST packet back, or are they not receiving a reply at all to their TCP connection?

    Jason

  3. #3
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    Ftp and telnet are disabled in the default installation of Redhat because they are insecure,

    enable telnet and ftp by edit the /etc/xinetd.d/telnet and /etc/xinetd.d/ftp files by setting disable no and then restart the xinted service with

    /etc/init.d/xinetd restart

    But if i where you i should use an SSH/SCP-server and SFTP-server instead that are more secure.
    Regards

    Andutt

  4. #4
    Just Joined!
    Join Date
    Feb 2003
    Posts
    28
    What they get is a "Connection refused"..

    I looked in /etc/xinetd.d/ and none of the files had permissions on. I chmod'ed them and will see if i can get someone to login and see what happens..

  5. #5
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    You're not supposed to chmod them. Those aren't scripts, they are configuration files, so open them with a text editor and see if you can find any line reading "disabled=yes".

  6. #6
    Just Joined!
    Join Date
    Feb 2003
    Posts
    28
    They say "Disabled=no"

    Can you treat me like an idiot and guid me through this like it was my first time...

    My last install was Slackware and it had it allready stup when i tunred on the computer i do beleive... Installed Redhat last week and am having a little trouble getting the things to work that i want..

  7. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Are you running a firewall. Check the output of "iptables -L -n" as root.

  8. #8
    Just Joined!
    Join Date
    Feb 2003
    Posts
    28
    I had thought about this, but i could not find it loaded anywhere. Thought that maybe it was hidden somewhere... So i used "locate iptables" and renamed every instance of it so it could not be found as iptables... But here is what it says when i run the command you told me too...


    thisisiptables -L -n
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

  9. #9
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    So that's not it...
    Check which interface they are listening on
    Code:
    netstat -antp | grep LISTEN

  10. #10
    Just Joined!
    Join Date
    Feb 2003
    Posts
    28
    My wonderful ISP is blocking port 80.

    I got everything to work. I had to tell httpd to Listen to another port, then use a dns service to add the port to the address. All is good. Thanks for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •