Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, I try to compile mysql-4.0.24 on my RHEL 3. As root I run:./configure -localstatedir=/usr/local/mysql/data -disable-maintainer-mode -with-mysql-user=mysql -prefix=/usr/local/mysql -enable-large-files-without-debug I get the following error: 050322 17:30:50 mysqld started 050322 17:30:51 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Location
    Germany
    Posts
    69

    mysql installation problem


    Hi,
    I try to compile mysql-4.0.24 on my RHEL 3.
    As root I run:./configure -localstatedir=/usr/local/mysql/data -disable-maintainer-mode -with-mysql-user=mysql -prefix=/usr/local/mysql -enable-large-files-without-debug

    I get the following error:

    050322 17:30:50 mysqld started
    050322 17:30:51 InnoDB: Operating system error number 13 in a file operation.
    InnoDB: See http://dev.mysql.com/doc/mysql/en/InnoDB.html
    InnoDB: for installation help.
    InnoDB: The error means mysqld does not have the access rights to
    InnoDB: the directory.
    InnoDB: File name ./ibdata1
    InnoDB: File operation call: 'create'.
    InnoDB: Cannot continue operation.
    050322 17:30:51 mysqld ended

    I've already created the mysql user and group.

    What I do wrong??


    thanks,
    ddaas

  2. #2
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    What is the file rights in your MySQL data directory?
    It should be "mysql" as owner and group.
    Get into your /usr/local/mysql/data and do a
    Code:
    chown -R mysql.mysql *
    should fix the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •