Find the answer to your Linux question:
Results 1 to 6 of 6
heres my error *** The gtk-config script installed by GTK could not be found *** If GTK was installed in PREFIX, make sure PREFIX/bin is in *** your path, or ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2003
    Posts
    67

    Ethereal install problem


    heres my error
    *** The gtk-config script installed by GTK could not be found
    *** If GTK was installed in PREFIX, make sure PREFIX/bin is in
    *** your path, or set the GTK_CONFIG environment variable to the
    *** full path to gtk-config.
    checking for glib-config... no
    checking for GLIB - version >= 1.2.0... no
    *** The glib-config script installed by GLIB could not be found
    *** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
    *** your path, or set the GLIB_CONFIG environment variable to the
    *** full path to glib-config.
    configure: error: GLib distribution not found.


    i'm running mandrake 9.1 and i know that gtk and glib are installed on my machine, im guessing that the install is not set to the right paths? Help

  2. #2
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    u need devel versions. (eg. gtk+2.0_0-devel-2.2mdk.i586.rpm or soemthign similar)

    also, check taht u have glib as well as glibc. mayeb u also need glib-config if there is such a thing.

  3. #3
    Just Joined!
    Join Date
    May 2003
    Posts
    67
    i did a check and its showing i have glibc-devel-2.3.1019mdk
    and i downloaded gtk+2.0-2.2.1-5mdk.src.rpm which says it provides
    * libgtk+2.0_0-devel
    * libgtk+-x11-2.0_0-devel
    * gtk+2-devel
    * libgtk+2-devel
    * libgtk+2.0-devel
    * libgtk+-x11-2.0-devel

    and i tried to install it and it said already installed. I know i have glib and glibc installed too.
    Any clues?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Jun 2003
    Location
    Minnesota, USA yes.....
    Posts
    479
    go to the mandrake control center you are in mandrake right? and type "gtk" install everything it comes up with then type "lib" and install everthing that comes up with. might work if not youll just have more packages to help future installations.

  6. #5
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I don't know if Mdk has the same package names, but the package you need is named gtk+-devel in RH.
    Also, you'll need to install the devel package for GTK 1.2, not for 2.0. 2.0 uses pkg-config instead of gtk-config. Don't worry, you don't need to downgrade, 1.2 and 2.0 can coexist on your system, and you probably already have both installed, just not the devel part of them.

  7. #6
    Just Joined!
    Join Date
    May 2003
    Posts
    67
    you guys are awsome, i just had to install the devel packages for glibc gtk that made that error go away, later on during the make i encountered another error, but i followed suit and had to install yacc (this is all totally NEW to me mind you!) and it worked, ethereal breathes!! Thanks so much for the help!

    Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •