Find the answer to your Linux question:
Results 1 to 3 of 3
Hello I am trying to setup an answering machine on my fc3 box. Kudzu configures my modem. I can make dailup connections. But voice mail doesn't work. Here is my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    1

    Answering machine with vgetty...


    Hello
    I am trying to setup an answering machine on my fc3 box.
    Kudzu configures my modem. I can make dailup connections. But voice mail doesn't work.
    Here is my vgetty.log.
    Thanks for any help.
    Code:
    03/31 11:53:07 yS0  vgetty: experimental test release 0.9.32 / 24Dec01
    03/31 11:53:07 yS0  mgetty: experimental test release 1.1.31-Jul24
    03/31 11:53:07 yS0  reading generic configuration from config file /etc/mgetty+sendfax/voice.conf
    03/31 11:53:07 yS0  reading program vgetty configuration from config file /etc/mgetty+sendfax/voice.conf
    03/31 11:53:07 yS0  reading port ttyS0 configuration from config file /etc/mgetty+sendfax/voice.conf
    03/31 11:53:07 yS0  check for lockfiles
    03/31 11:53:07 yS0  locking the line
    03/31 11:53:07 yS0  lowering DTR to reset Modem
    03/31 11:53:08 yS0  send: \dATQ0V1H0[0d]
    03/31 11:53:09 yS0  waiting for ``OK'' ** found **
    03/31 11:53:09 yS0  send: ATS0=0Q0&D3&C1[0d]
    03/31 11:53:09 yS0  waiting for ``OK'' ** found **
    03/31 11:53:09 yS0  mdm_send: 'ATI'
    03/31 11:53:09 yS0  non-numeric ID string: 'Hayes V.92 Serial s1117d00 -A  H207'
    03/31 11:53:09 yS0  mdm_send: 'AT+FCLASS=2.0' -> ERROR
    03/31 11:53:09 yS0  mdm_send: 'AT+FCLASS=2' -> OK
    03/31 11:53:09 yS0  mdm_send: 'AT+FCLASS=0' -> OK
    03/31 11:53:09 yS0  mdm_send: 'AT+FAA=1;+FCR=1' -> OK
    03/31 11:53:09 yS0  mdm_send: 'AT+FBOR=0' -> OK
    03/31 11:53:09 yS0  mdm_send: 'AT+FLID="49 115 xxxxxxxx"' -> OK
    03/31 11:53:09 yS0  mdm_send: 'AT+FDCC=1,5,0,2,0,0,0,0' -> OK
    03/31 11:53:09 yS0  detecting voice modem type
    03/31 11:53:13 yS0  vgetty: Modem returned ERROR
    03/31 11:53:13 yS0  no voice modem detected

  2. #2
    Linux Newbie
    Join Date
    Dec 2004
    Location
    Barrie, Ontario
    Posts
    219
    It's been a few years since I messed with vgetty, but as I recall, that error would mean it doesn't recognize the device as a voice enabled modem...
    Blog - KB5UMQ - Linux User #272983
    3 Rules:
    1) "It doesn't work..." is simply not useful information.
    2) Don't cross post!
    3) If you are asking for help, start by telling us your distro/os and version.

  3. #3
    Linux Newbie daacosta's Avatar
    Join Date
    Sep 2005
    Location
    Medellín, Colombia
    Posts
    213
    Quote Originally Posted by cybervolkan
    Hello
    I am trying to setup an answering machine on my fc3 box.
    Kudzu configures my modem. I can make dailup connections. But voice mail doesn't work.
    Here is my vgetty.log.
    Thanks for any help.
    Code:
    03/31 11:53:07 yS0  vgetty: experimental test release 0.9.32 / 24Dec01
    03/31 11:53:07 yS0  mgetty: experimental test release 1.1.31-Jul24
    03/31 11:53:07 yS0  reading generic configuration from config file /etc/mgetty+sendfax/voice.conf
    03/31 11:53:07 yS0  reading program vgetty configuration from config file /etc/mgetty+sendfax/voice.conf
    03/31 11:53:07 yS0  reading port ttyS0 configuration from config file /etc/mgetty+sendfax/voice.conf
    03/31 11:53:07 yS0  check for lockfiles
    03/31 11:53:07 yS0  locking the line
    03/31 11:53:07 yS0  lowering DTR to reset Modem
    03/31 11:53:08 yS0  send: \dATQ0V1H0[0d]
    03/31 11:53:09 yS0  waiting for ``OK'' ** found **
    03/31 11:53:09 yS0  send: ATS0=0Q0&D3&C1[0d]
    03/31 11:53:09 yS0  waiting for ``OK'' ** found **
    03/31 11:53:09 yS0  mdm_send: 'ATI'
    03/31 11:53:09 yS0  non-numeric ID string: 'Hayes V.92 Serial s1117d00 -A  H207'
    03/31 11:53:09 yS0  mdm_send: 'AT+FCLASS=2.0' -> ERROR
    03/31 11:53:09 yS0  mdm_send: 'AT+FCLASS=2' -> OK
    03/31 11:53:09 yS0  mdm_send: 'AT+FCLASS=0' -> OK
    03/31 11:53:09 yS0  mdm_send: 'AT+FAA=1;+FCR=1' -> OK
    03/31 11:53:09 yS0  mdm_send: 'AT+FBOR=0' -> OK
    03/31 11:53:09 yS0  mdm_send: 'AT+FLID="49 115 xxxxxxxx"' -> OK
    03/31 11:53:09 yS0  mdm_send: 'AT+FDCC=1,5,0,2,0,0,0,0' -> OK
    03/31 11:53:09 yS0  detecting voice modem type
    03/31 11:53:13 yS0  vgetty: Modem returned ERROR
    03/31 11:53:13 yS0  no voice modem detected

    Could you please post your /etc/mgetty+sendfax/voice.conf file? Maybe the problem is that voice.conf is looking for the modem at the wrong place
    -D-

    Registered User # 402675

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •