Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
that ternimal u are trying to start it from, is that an emulate dterminal, eg. clicking the ternimal button ina window manager? or is it 1 u get to by ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766

    that ternimal u are trying to start it from, is that an emulate dterminal, eg. clicking the ternimal button ina window manager? or is it 1 u get to by pressign ctrl+alt+f1 etc.

    if u try to run graphical programs from a non emulated terminal the display wont start.

    try loggin in as notmal user. startign gnome/kde/whatever then click the terminal button there. now su to root. now type ripperX or whatever starts it.

  2. #12
    Linux Newbie
    Join Date
    Jun 2003
    Posts
    160

    X

    It is an emulated terminal

    I tried logging in as root under KDE and running it and I still get the same error message... can't access /dev/cdrom -> I'll look around and see if I can't find a config file somewhere and getr back to you

    Cole

  3. #13
    Linux Newbie
    Join Date
    Jun 2003
    Posts
    160

    .ripperXrc

    The resource file for RipperX doesn't have anything relating to which device to use - is there a config file for CDPARANOIA (what ripperX uses) that specifies which device to use????

    Cole

  4. #14
    Linux Newbie
    Join Date
    Jun 2003
    Posts
    160

    I found it

    I found a setting in the ripperX program that allows you to IGNORE /dev/cdrom - it will let me rup off the regular CDROM but NOT from the burner I suppose I'll have to deal...

    here's what I did - I would like to write a script so that I can add this to my dock but I don't know anything about it - here's the shell session I used...

    cole@DrSpin:~> echo ~/.Xauthority >/tmp/xauth
    cole@DrSpin:~> echo $DISPLAY >/tmp/xdisp
    cole@DrSpin:~> su
    Password:
    DrSpin:/home/cole # export DISPLAY="$(cat /tmp/xdisp)"
    DrSpin:/home/cole # export XAUTHORITY="$(cat /tmp/xauth)"
    DrSpin:/home/cole # ripperX &
    When I launch SuSE programs it pops up with a nice box asking for my root password - something like that would be OK but again I don't know anything about it :S Any ideas??

    Cole

  5. #15
    Linux Newbie
    Join Date
    Jun 2003
    Posts
    160

    kdesu

    Who'd have thought that it would be that easy

    Thanks for the help the button comand is:
    kdesu ripperX

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •