Find the answer to your Linux question:
Results 1 to 4 of 4
K Rec doesn't want to cooperate right now, I plugged a tape deck into the "Line In" jack on my soundcard and made sure that the sound card was configured ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Location
    Down by the old oak grove
    Posts
    34

    K-Rec/aRts


    K Rec doesn't want to cooperate right now, I plugged a tape deck into the "Line In" jack on my soundcard and made sure that the sound card was configured for full duplex.
    Logged in as root, I followed the directions to the letter, opened aRtscontrol and its audio manager to make sure "KRec::In" was connected to the "in_soundcard" bus, set the volume and recording source in KMix and although the sound from the tape deck is coming through the computer speakers and the volume is adjustable with KMix, the VU meters on aRts Control and KRec aren't moving, which means that for some reason aRts (And therefore, KRec) isn't getting a signal. See screenshot.
    I also tried recording from the "out_soundcard" bus while playing WAVE files on XMMS, which worked perfectly. See screenshot.
    So what went wrong? As far as I know I did it right, so K Rec should be getting a signal from line, right?

    The sound system on this computer is a Realtek ALC202/A 18 Bit AC'97 CODEC Specifications here. The OS is RedHat Enterprise Linux Professional Workstation III

    Artsshell status outputs:

    server status: busy
    real-time status: not started through real-time wrapper
    server buffer time: 46.4399 ms
    buffer size multiplier: 1
    minimum stream buffer time: 46.4399 ms
    auto suspend time: 0 s
    audio method: oss
    sampling rate: 44100
    channels: 2
    sample size: 16 bits
    duplex: full
    device: /dev/dsp
    fragments: 8
    fragment size: 1024

  2. #2
    Just Joined!
    Join Date
    May 2005
    Location
    Down by the old oak grove
    Posts
    34
    No suggestions huh?

  3. #3
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Tried KRec before, but it did'nt work at all so I switched to audacity. Make sure aRts is'nt blocking for audacity if you decide to try

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2006
    Posts
    6

    Fix it in KMix

    Darkbackwardz,

    I had the same problem. I fixed it by accident. Start KMix and go the switches tab. Make sure that both of the Input Source Select boxes are set to Input1.

    Good luck!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •