Find the answer to your Linux question:
Results 1 to 3 of 3
I have a Gen. 4 ipod and I compiled gtkpod-0.88.2. When I mount the iPod with root, gtkpod can read what is in it, but it gets this error whenever ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    45

    two errors while using gtkpod


    I have a Gen. 4 ipod and I compiled gtkpod-0.88.2.

    When I mount the iPod with root, gtkpod can read what is in it, but it gets this error whenever I tell gtkpod to read it:

    Code:
    Could not open "iTunesDB.ext" for reading extended info.
    Extended info will not be used.
    Whenever I try "Sync" after making changes, I get:

    Code:
    Could not open file "/mnt/ipod/iPod_Control/Music/F08/gtkpod00119.mp3" for writing.
    Any ideas or help would be appreciated,

    thanks,

    mr.popper[/code]

  2. #2
    Just Joined!
    Join Date
    May 2005
    Location
    south australia
    Posts
    20

    no more errors with gtkpod!! =o)

    i spent a few hours tonight messing with my ipod mini on my fedora core 3 system using gtkpod 0.88.

    the solution to the problem you describe (exact same problem as mine) is this:

    * create an entry in your fstab that includes "uid=500, gid=500" for your ipod (eg: /dev/sda2 /media/myipod vfat pamconsole,exec,noauto,iocharset=utf8,managed,uid= 500,gid=500 0 0)

    * change ownership of your mountpoint to match the uid used in your fstab
    (eg: chown 500 /media/myipod)

    thats about it. i trust this will help some folks having the same problem and using distros other than fc3.

    a note for fc users is not to manually create a mountpoint like i originally did (/mnt/ipod). the system (pamconsole???) auto mounts the usb device and creates an fstab entry for it. creating a new mountpoint and manually mounting it is unecessary.

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    1

    Re: no more errors with gtkpod!! =o)

    Hi,

    I would like to think that the uid=500,gid=500 should match your personal user ID or it won't work either. Changing the permissions of the mount point never had any effect on my system.

    Also, using the utf8 charset for a vfat filesystem is a BAD idea as it makes the filenames case sensitive. So trying to write to .../F00/... may turn out an error because on your system it is .../f00/... It's was quite a pain to make gtkpod at least partly resistant to these problems.

    The best way for the iPod to be mounted is using the automounter, in my opinion. See the README file (http://www.gtkpod.org/README) for details on how to manually set it up.

    One more thing: it's a very good idea to add the "sync" option to the fstab / automounter options because it will prevent you from accidentially disconnecting the iPod while the buffer is still being flushed. With the option in place, write commands won't return until all buffers are flushed. In addition I always check with 'df' or 'mount' whether the iPod is unmounted or not before disconnecting.

    Cheers,


    JCS.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •