Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I"m trying to get any sound working at all. My main goal however, is to get xmms working. I'm using slackware. I did alsaconf and changed the driver to alsa ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    89

    Sound in Slackware


    I"m trying to get any sound working at all. My main goal however, is to get xmms working. I'm using slackware. I did alsaconf and changed the driver to alsa in xmms and said it "couldnt open audio" Alsa has worked PERFECTLY, before though. Thanks for any help!

  2. #2
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Buenos Aires, Argentina
    Posts
    908
    Try adding your user to the "audio" group. Chjeck with the groups command if you're already in that group, if you're not, you can add yourself with the following command.

    usermod -G audio username
    Do it as root, remplacing that "username" for your user, heh. By doing this we discard that it's not a permissions problem.

    Hope this helps.
    serzsite.com.ar
    "All the drugs in this world won\'t save you from yourself"

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    89
    Nah, Didnt work. Still, "couldn't open audio"

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    You're sure that it's not the audio file it can't open? Usually it sais "audio device" or something... Also, make sure there aint any software mixer blocking the sound-device, like for example esound (esd) or artsd, in that case you must either shut them down or change the audio-plugin to esd or arts.

  6. #5
    Just Joined!
    Join Date
    Apr 2005
    Posts
    89
    The only thing I'm running besides xmms is a terminal and gaim. It's not the audio file because I just downloaded another one, and got the same error...
    oh, well now, I double click the audio file, and it changes skins, and wont play.

  7. #6
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    What I meant is that some audio formats need additional XMMS plugins. You should check what filetype you're opening and check in the XMMS settings. As I said, also check for esd or artsd running like this (post the output):
    Code:
    ps -ef|grep esd
    ps -ef|grep artsd

  8. #7
    Just Joined!
    Join Date
    Apr 2005
    Posts
    89
    Well, i'm not really sure what the command, or the output means, but here it is
    Code:
    bash-3.00# ps -ef|grep esd
    root      5055  1708  0 10:53 pts/2    00:00:00 grep esd
    bash-3.00# ps -ef|grep artsd
    zach      1483  1466  0 Jun04 ?        00:00:10 artsd -F 10 -S 4096 -s 60 -m artsmessage -c drkonqi -l 3 -f
    zach      1493  1483  0 Jun04 ?        00:00:00 artsd -F 10 -S 4096 -s 60 -m artsmessage -c drkonqi -l 3 -f
    bash-3.00#

  9. #8
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Aha, there the problem lies. You are using a software-mixer (arts). You could either turn off arts in kcontrol, or download/install an arts-plugin for xmms.

    For more info about the commands, try "man ps" and "man grep".

  10. #9
    Just Joined!
    Join Date
    Apr 2005
    Posts
    89
    Well, I'm not sure what a software mixer is, right now. But I would like to turn it off, so all my sound will work, not just xmms. Could you explain how to do it in kcontrol. I dont see any options...

    Edit: Ohhh, I just disabled the sound system. Now my problem is, xmms is being weird, it wont add any files to the playlist, and i still dont know if it works

  11. #10
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Do you know if the format you're trying to play is supported by XMMS? For example I think you need extra plugin for WMA in XMMS, and fedora patches away MP3-support...

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •