Find the answer to your Linux question:
Results 1 to 3 of 3
Greetings there.. i tried to run eclipse on madrake . could not .. got the following error... Code: !SESSION May 29, 2005 12:56:48.485 --------------------------------------------- eclipse.buildId=I200406251208 java.version=1.4.2_05 java.vendor=Sun Microsystems Inc. BootLoader ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    35

    Eclipse on Madrake


    Greetings there..
    i tried to run eclipse on madrake .
    could not .. got the following error...

    Code:
    !SESSION May 29, 2005 12:56:48.485 ---------------------------------------------
    eclipse.buildId=I200406251208
    java.version=1.4.2_05
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
    
    !ENTRY org.eclipse.osgi May 29, 2005 12:56:48.487
    !MESSAGE Application error
    !STACK 1
    [b]java.lang.RuntimeException: Application "org.eclipse.ui.ide.workbench" could not be found in the registry.[/b] The applications available are: org.eclipse.ant.core.antRunner, org.eclipse.pde.build.BuildScriptGenerator, org.eclipse.pde.build.FetchScriptGenerator, org.eclipse.update.core.standaloneUpdate, org.eclipse.pde.junit.runtime.uitestapplication, org.eclipse.pde.junit.runtime.legacyUItestapplication, org.eclipse.pde.junit.runtime.coretestapplication.
    	at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:325)
    	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:273)
    	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:129)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:324)
    	at org.eclipse.core.launcher.Main.basicRun(Main.java:183)
    	at org.eclipse.core.launcher.Main.run(Main.java:644)
    	at org.eclipse.core.launcher.Main.main(Main.java:628)
    
    rest all comments...
    i got these things installed...

    Name: gtk+2.0
    Version: 2.4.9-9.1.101mdk
    Size: 7880 KB
    Medium: update_source
    Currently installed version: 2.4.9-9mdk

    Name: glibc
    Version: 2.3.3-23.1.101mdk
    Size: 9983 KB
    Medium: update_source
    Currently installed version: 2.3.3-21mdk

    Pango-not installed

    [rohitsz@localhost home]$ java -version
    java version "1.4.2_05"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_05-b04)
    Java HotSpot(TM) Client VM (build 1.4.2_05-b04, mixed mode)
    [rohitsz@localhost home]$

    eclipse-SDK-3.0-linux-gtk.zip

    kindly help me run eclipse..

    thanks,
    rohit.

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    I'm not a java expert, that'd be Techiemoe, but...

    I've had numerous issues with the MDK Java RPM. Install the binary SDK (NOT JVM) from the sun website. Make sure you've exported all the correct variables, path to Java, JAVA_CLASSPATH, JAVA_HOME, etc...

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    35
    Greetings there jeremy..
    well i have the SUN-Java installed and its working fine ...the reason i say this is.. i tried to run eclipse by removing java from the path and it instantly gave me the error of JVM not found .. on putting java back in path.. i saw hat the same error appeared...

    so i guess its not a problem with the path of java or the run-time environment...

    any more pointer in solving the prob would be help-ful..
    regards,
    rohit.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •