Find the answer to your Linux question:
Results 1 to 6 of 6
I'm having a very strange issue with the GIMP's initial setup and startup when I'm operating as my user account... It gets all the way through the setup and then ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    25

    GIMP starts as root, not as my user...


    I'm having a very strange issue with the GIMP's initial setup and startup when I'm operating as my user account...

    It gets all the way through the setup and then when I hit "continue" on the calibration screen to supposedly start the program, it crashes. When I run it as kdesu, it works fine. I've reloaded both the GIMP and glib through YaST, and it still doesn't work.

    The command line output is the same thing about 30 times...and it's this:
    (gimp:17724): GLib-GObject-CRITICAL **: file gobject.c: line 1579 (g_object_unref): assertion `G_IS_OBJECT (object)' failed

    I'm at a loss on what to do to fix it or why it works as root and not as me...any ideas?

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    25
    More info: Here is how the error changes when you try to run it after it completes its "setup" and crashes once...

    Kari@linux:~> gimp

    (gimp:18710): GLib-GObject-CRITICAL **: file gobject.c: line 1579 (g_object_unref): assertion `G_IS_OBJECT (object)' failed

    (gimp:18710): GLib-GObject-CRITICAL **: file gobject.c: line 1579 (g_object_unref): assertion `G_IS_OBJECT (object)' failed
    Segmentation fault

    (script-fu:18877): LibGimpBase-WARNING **: script-fu: wire_read(): error



    Mr. Panic and I are both at a loss here...any ideas would be much appreciated

  3. #3
    Linux Engineer
    Join Date
    Jan 2005
    Location
    Chicago (USA)
    Posts
    1,028
    Try using KFind, find or locate to locate everything with *gimp* in you home directory. Then delete all of that.

  4. #4
    Just Joined!
    Join Date
    May 2005
    Posts
    25
    It didn't find anything outside of the /home/Kari/.gimp folder, and I've already deleted that and tried again about 6 or 7 times. Even tried gimprc and gtkrc files out of the root directory and then off of another machine, still no go...

  5. #5
    Just Joined!
    Join Date
    Jun 2005
    Location
    Holland
    Posts
    8
    This is due to a crap version of gtk-qt-engine being used. If you're on 9.2 then it's been updated by YaST, if you're on 9.3 then it installs it by default. The crap version is something like gtk-qt-?? cvs???????. Note the CVS in the package name.

    To correct the problem install the gtk-qt-engine0.5-9 that comes on the 9.2 disks. If you don't have the 9.2 disks, take it from the SUSE ftp server - go into the 9.2 version tree though.

    Incidently, this also solved a problem I was having with firefox after upgrading to 9.3.

    Hope it works for you.
    Chris

  6. #6
    Linux Newbie ihayhurst's Avatar
    Join Date
    Jun 2005
    Location
    UK
    Posts
    138
    Works for me,
    Thanks that one had been driving me slowly nuts
    found it here for reference
    ftp://ftp.mirrorservice.org/sites/ft...5-9.3.i586.rpm

    Ian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •