Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Well as you know im most likely the BIGGEST N00be ever but i cant find Bit Torrent Client compiled anywhere for Linux :S which i used ALL the time on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2003
    Posts
    10

    Bit Torrent


    Well as you know im most likely the BIGGEST N00be ever but

    i cant find Bit Torrent Client compiled anywhere for Linux :S

    which i used ALL the time on windows

    can someone who isnt a stupid n00be compile it for me? or perhaps show me the right direction?

    Pleaseee

  2. #2
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    I searched around and couldn't find any RH9 rpm's, so unless anyone else knows of one you're going to have to do this the old fashioned way. First you're going to need Python, which is a programming language. Then you're going to need to install wxPython, which is a GUI for Python. Both can be found at www.python.org and www.wxpython.org. There is no rpm for Python that I know of, but there is for wxPython. It's gonna be a bit of work on your part, so if you still want to go through with it I could walk you through it, unless someone else has an easier solution for this fellow.

  3. #3
    Just Joined!
    Join Date
    Aug 2003
    Posts
    10
    :S
    Aw well am gonna have to learn how to compile sooner or later cant hide behind RedHat RPM's forever :P

    lol

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    It's really not that bad once you know the basics. I almost always compile over using RPMs, (well now that I use Gentoo I don't have to worry about that anymore ) there's a lot more choice and controll, and it just plain works better. OK I'll take you through the steps so you can get this set up rather hastle free:

    1. Go to http://www.python.org/2.3/ and download the Python-2.3.tgz tarball.
    2. Open up a terminal and cd /pathname/of/where/it's/saved
    3. tar -xzvf Python-2.3.tgz
    4. cd Python-2.3
    5. ./configure
    6. make
    7. su root, give password
    8. make install

    Thats it for Python, now onto wxPython.

    1. download this http://prdownloads.sourceforge.net/w....1.2-1.src.rpm and install it.

    Now onto BitTorrent.

    1. download this http://bitconjurer.org/BitTorrent/Bi...-3.2.1b.tar.gz
    2. back in the terminal, type tar -xzvf BitTorrent-3.2.1b.tar.gz
    3. open a terminal, su root and open up a text editor.
    4. open /etc/mailcap
    5. add the following line somewhere, only replace the /usr/bin/ to where ever you extracted it:

    application/x-bittorrent; /usr/bin/btdownloadgui.py %s; test=test -n "$DISPLAY"

    6. restart your browser and that should be it.

    That's it, this SHOULD work for you. Keep in mind I took this info for the BitTorrent from the INSTALL-unix.txt file in the BitTorrent folder. I have no idea how BitTorrent is used, so the rest is up to you to figure out how to use it in Linux. A quick note on compiling: as you can see, it's really not so bad. The thing to remember is always look in the folder for README and INSTALL files, they usually answer any questions or point out any specifics you need to do. You also have the choice to where things are going to be installed, by adding --prefix=/pathname after the ./configure. Good luck, reply if you have any problems.

  6. #5
    Just Joined!
    Join Date
    Aug 2003
    Posts
    2
    I'm unable to add a line to /etc/mailcap. It's a read only file and when I try to change that it tells me acces is denied.

  7. #6
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    Did you su root before you opened the text editor through the terminal?

  8. #7
    Just Joined!
    Join Date
    Aug 2003
    Posts
    2
    No. I just did it and everything has worked out. Thanks for the help.

  9. #8
    Just Joined!
    Join Date
    Jan 2004
    Posts
    48
    iI tried this and it did not work. Perhaps my browser (mozilla 1.6 i think) doesnt use the mailcap file for reference. Is there somewhere else i can go to add that for mozilla to use it. Now i went into a BT irc chat for a while and none of their ideas worked (enable total permission etc...) Does anyone know possibly what the problem is, because btdownloadgui.py simply doesnt do anything either when a torrent is opened in a browser, or is downloaded and i select that as the application to open the .torrent. Thanks.

  10. #9
    Just Joined!
    Join Date
    May 2004
    Posts
    6
    Hi. Look, even if you get to be able to use the official bittorrent client,
    ( which by the way is used iin the following way:
    1. Save the .torrent file to your hd.
    2. From the command line, cd to the folder where btdownloadgui.py is.
    3. Type btdownloadgui.py /yourtorrentsadrees/yourtorrentname

    *note: I never could make opera or mozilla get to *catch* the .torrent to automatically open the files)

    you will find that the interface looks very primitive, so, I recommend you look download Azureus, its java based, the interface is very friendly and, and it works great. You can find it here:
    http://azureus.sourceforge.net/
    and do this:
    http://azureus.sourceforge.net/howto_linux.php

  11. #10
    Just Joined!
    Join Date
    Jan 2004
    Posts
    48
    ok well i tried all of that and i get this

    [root@localhost azureus]# ./azureus
    Attempting to start Azureus...
    ./azureus: line 52: java: command not found

    No i installed the jaza jre or wahtever before from the rpm.bin the install went fine i extracted the rpm and then installed in the terminal with no errors. What is the problem, does anyonme know?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •