Find the answer to your Linux question:
Results 1 to 8 of 8
Hi, I'm using, Slackware 10.1 KDE 3.3 When I select a screensaver in the control center and click on the "test" button, the screen saver works well. However, if I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Location
    India
    Posts
    21

    Screensaver Not Starting in KDE 3.3


    Hi,

    I'm using,
    Slackware 10.1
    KDE 3.3
    When I select a screensaver in the control center and click on the "test" button, the screen saver works well.

    However, if I lock the KDE session or if the time for starting screensaver is out, the screensaver does not start. The screen simply goes blank.

    How can I get around this??

  2. #2
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    I seemed to have the same problem in mandriva 10.1 CE some months ago, but that was with KDE 3.2 thought. In my place, it started working when I removed xscreensaver.

  3. #3
    Linux Newbie
    Join Date
    Apr 2005
    Location
    NJ, USA
    Posts
    104

    3.4

    I have slackware 10.1 and KDE 3.4 and I was dismayed that it didn't have my favorite screensaver(BSOD, stands for Blue Screen Of Death.). So I downloaded the latest xscreensaver version (no sure what this is).I installed it and KDE finds all of the screensavers. However After 5 minutes when my screensaver is suppose to switch on The screen goes blank. In the control center I can "Test" the screensaver so I know it works.Any Ideas?
    My New years Resolution is 1280x1024

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2005
    Posts
    3

    Mybe permissons problem...

    Hi,

    I got Slackware 10.1, KDE 3.4 and the same problem when logged NOT as root.
    However I noticed that if I log in as root, all the screensavers installed are running and OK.
    The permissions of the screensaver files (or at least the files I think are screensavers - I cannot quote the exact location, since I am not at home) are set to 666...

  6. #5
    Just Joined!
    Join Date
    Apr 2005
    Location
    India
    Posts
    21
    Removing xscreensaver made it work.

    But, I lost many nice screensavers like xflames.

  7. #6
    Just Joined!
    Join Date
    Mar 2005
    Posts
    3

    Possible solution

    OK, here is a possible solution to this issue.
    DO NOT use the KDE desktop settings to set the screensaver. Do use xscreensaver-demo instead. It is a bit buggy and crashes from time to time, but at least you may pick any of the screensavers. Moreover, it gives you more advanced options.

  8. #7
    Just Joined!
    Join Date
    Jul 2005
    Posts
    33
    i have the same problems in knoppixwhich is installed to hd i can preview the screensavers but when they start auto screen just goes blank

  9. #8
    Just Joined!
    Join Date
    Aug 2005
    Posts
    1
    Same problem was on SuSE 9.3, KDE 3.4.0

    I had to change the Kpowersave Settings: Tab General Settings -> Lock screen with:

    Change it from "select automatically" to "XScreensaver"

    Now the screensaver starts when I lock the screen.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •