Find the answer to your Linux question:
Results 1 to 2 of 2
Hi everyone, I'm new to this forum and not very experienced with the linux world either. I don't know why but today my mplayer just doesn't work. I have a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    2

    Mplayer problems


    Hi everyone, I'm new to this forum and not very experienced with the linux world either. I don't know why but today my mplayer just doesn't work. I have a Ubuntu Hoary 5.04. This is what I get if I launch it from terminal:

    :~ $ gmplayer
    MPlayer 1.0pre6-3.3.5 (C) 2000-2004 MPlayer Team
    CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino (Family: 6, Stepping: 2)
    Detected cache-line size is 64 bytes
    CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
    Compiled for Debian.



    vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
    73 audio & 180 video codecs
    Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
    Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
    Opening joystick device /dev/input/js0
    Can't open joystick device /dev/input/js0 : No such file or directory
    Can't init input joystick
    Setting up LIRC support...
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support.
    You will not be able to use your remote control.

    Gtk-WARNING **: Cannot find module in module directory: "libindustrial.so",

    Exiting... (Quit)

    Can anyone help me solving the problem? Thanks in advance.

  2. #2
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    Which version of gtk do you have installed? The applications have to use the same version of gtk in order for them to find the modules in the directory, in this case the module not found is located at (example) /usr/lib/gtk-2.0/2.4.0/engines/libindustrial.so

    You can first try the command ldconfig as root in order to see if that updates the library locations, or if that fails you may want to consider upgrading gtk. Compiling mplayer from source may also do the trick in order to make sure that it's using the version of gtk that you have, the reason I put that last is because it would be easier to upgrade gtk and solve this problem and any further problems you may have down the line with other programs than to simply iron out this one kink

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •