Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 21
I had this problem and had to remove kaffeinerc from /.kde/share/config as well as the enitre /.kde/apps/share/kaffeine folder, that sorted it....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    unknown
    Guest

    I had this problem and had to remove kaffeinerc from /.kde/share/config as well as the enitre /.kde/apps/share/kaffeine folder, that sorted it.

  2. #12
    Just Joined!
    Join Date
    Jul 2005
    Posts
    2
    ok, i deleted those folders and i still get the error after kaffeine's wizard says that my kaffeinepart is ok. i looked into mplayer but i'm not comfortable with compiling stuff at all since i'm very new to linux so i'm probably not even going to touch that because of all those dependencies.

    i also tried using rpms from packmans site instead of the one i was using earlier but this didnt solve the problem.

  3. #13
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    Have you installed libdvdcss? The descrambling libraries for dvd playback?
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Jul 2005
    Location
    Indiana
    Posts
    2

    Yeah, me too...

    I have Suse 9.2 running on a Compaq laptop with an ATI graphics card. I didn't have any problems running Kaffiene and Xine until today. I ran the automatic update, and noticed a device driver update for my ATI graphics card. After YAST finished, I found that I could no longer play my videos. I get the exact same error: "All Video Drivers failed to intialize!". I've already tried what has been suggested with removing kaffienerc and .kaffiene/ . Any other suggestions? Heres the command line output when I try to run xine now:

  6. #15
    Linux Engineer LondoJowo's Avatar
    Join Date
    May 2005
    Location
    Richmond, TX
    Posts
    804
    Did you run SaX2 after you installed the ATi driver updates? I have learned that this must be done when updating driver for either ATi or nVidia..

  7. #16
    Linux User Muser's Avatar
    Join Date
    May 2004
    Location
    Maryland
    Posts
    363
    Have you tried updating the xine codecs? Isn't there a xine-codecs package?

  8. #17
    Just Joined!
    Join Date
    Jul 2005
    Location
    Indiana
    Posts
    2
    okay, now I have uninstalled and reinstalled all xine related packages, and I still get the error. Could it be my new graphics drivers? I've also run SaX2, but that didn't seem to help. I can't seem to find my graphics drivers in YaST. Can anyone tell me how to roll back my driver to a previous version?

  9. #18
    Just Joined!
    Join Date
    Nov 2006
    Posts
    4

    Cool Kaffeine and Xine fixed for me ... try this

    I've spent many hours on this now ... and it's relatively simple to fix. First make sure your packages are up to date And don't change xine-ui like I've seen on some boards no need to change the lib either. Look in ~./xine/plugins/ see if there are directories 1.1.1 and 1.1.3 ... I read my kaffeine backtrace and found the directory being used was 1.1.1, thing is because of all the updates etc the plugins are actually in 1.1.3. I tgz'd 1.1.1 and cp 1.1.3 to 1.1.1 and kaffeine is working great as well as xine. Only had to set the video to be xv in xine settings through the gui. Copied a ttf file for the font error message into ./mplayer it also works. I looked in the xine config file and didn't see a plugin path.

    Good luck hope this helps everyone

    The ati nvidea drivers need some attention read this below and follow word for word to check it works, if after an init 3 you don't see what you want with lsmod then reboot

    ATI video drivers

    SUSE Linux 10.1 ships with the newly revamped open source radeon driver. That may be fine for 2D rendering, but it doesn't do direct rendering for 3D graphics. To get hardware 3D acceleration (and for XGL support), you still need the proprietary ATI fglrx driver.

    Go to the ATI Web site, click on Drivers & Software, then Linux Display Drivers and Software, then on the driver appropriate to your video card. 32-bit SUSE installations need the x86 drivers, and 64-bit SUSE needs the x86_64 versions. After you have clicked the link for your card, yet another link comes up. Click it, scroll down to the downloads table, then right-click the ATI Driver Installer download link and save it to your home directory. You do not need to download any of the other packages.

    After the file transfer completes, close all open programs, then press ctrl-alt-F1 to switch to the first virtual terminal. You'll see a text-mode login prompt; log in as root. When you're at the command prompt, type in this command:

    init 3

    You'll see a bunch of text scroll by, and then a message saying that runlevel 3 has been reached. Press Enter to get the command prompt back, then type the following command in to switch to the directory you downloaded the ATI driver to:

    cd /home/username/

    Substitute your user name for "username" in the above example. Now you need to change the ATI installer permissions so that it can be run from the command line.

    For long file names, you don't have to type the whole name into a terminal window. Instead, just type the first few letters and then press the Tab key, and the file name will be automatically completed for you. This is useful in situations like the one you're in now, where there is a long and complex file name to type in. So type the following command into your terminal, and use the Tab key to complete the ATI driver file name, then press Enter to execute the command:

    chmod +x ./ati-driver

    That will make the program executable; this must be done before you can run it. Now it's time to run the installer. Again, use tab completion instead of typing the name in. You have to add the ./ before the filename to tell the terminal program that the file you are referring to is in the current directory. If you don't specify that, the terminal will look in other places for the file. It sounds crazy, yes, but that's the way GNU/Linux is (and Unix before it). For the below example, the entire file name is typed in. Please note that this may not be the same file name that you downloaded -- it is only an example. You should use tab completion when you type this command in so that you don't accidentally mis-type the long file name. The part of the example that will not change is the switch statement after the file name (the part with the dashes). Here's the example command for the ATI driver installer for a 32-bit system:

    ./ati-driver-installer-8.24.8-x86.run --buildpkg SuSE/SUSE101-IA32

    And for a 64-bit system:

    ./ati-driver-installer-8.24.8-x86_64.run --buildpkg SuSE/SUSE101-AMD64

    After a few dozen lines of text, a driver package will be created. Go ahead and run it with the following command (the first example is for 32-bit systems):

    rpm -ivh fglrx_6_9_0_SUSE101-8.24.8-1.i386.rpm

    And for 64-bit systems:

    rpm -ivh fglrx64_6_9_0_SUSE101-8.24.8-1.x86_64.rpm

    Update your system environment variables with this command:

    ldconfig

    Next, you need to tell SUSE that you want to use this driver instead of the standard one:

    aticonfig --initial --input=/etc/X11/xorg.conf

    Lastly, you have to tell YaST which driver to load (that's a zero in the example, not a letter):

    sax2 -r -m 0=fglrx

    Now reboot your computer by typing the following command:

    reboot

    The next time your system starts, you'll have hardware 3D video acceleration. Please note that every time you update your kernel, you must re-install the ATI video driver.
    Nvidia video drivers

    SUSE Linux 10.1 no longer includes the proprietary Nvidia graphics driver, but Nvidia does provide a SUSE installation source for YaST. Add this to your Installation Sources screen in YaST as instructed above:

    download.nvidia.com/novell

    Once it's been added, close YaST and right-click the ZENworks notification icon in the lower right corner of your screen. Click Refresh in the popup menu, then wait for ZENworks to check for updates -- it could be several minutes. ZENworks should find the Nvidia kernel pacakge and notify you that updates are available. Left-click on the ZENworks icon when it turns into an orange circle, make sure all of the available packages are selected, then go ahead and apply the updates. When ZENworks is done, restart your computer. When next you log into SUSE Linux, you should have hardware 3D acceleration enabled. To check, run this program from a terminal program (the computer screen icon in the lower left, between the house icon and the life preserver):

    glxinfo

    Dozens of lines of text should result from this command. Look near the top for the Direct Rendering line. If it says Yes, you're all set. If it says no, make sure ZENworks isn't still listing the Nvidia packages as updates. If it is, try this process again or visit our forum and ask for help.

  10. #19
    Just Joined!
    Join Date
    Nov 2006
    Location
    Toronto, Ont.
    Posts
    4
    I've spent many hours on this now ... and it's relatively simple to fix. First make sure your packages are up to date And don't change xine-ui like I've seen on some boards no need to change the lib either. Look in ~./xine/plugins/ see if there are directories 1.1.1 and 1.1.3 ... I read my kaffeine backtrace and found the directory being used was 1.1.1, thing is because of all the updates etc the plugins are actually in 1.1.3. I tgz'd 1.1.1 and cp 1.1.3 to 1.1.1 and kaffeine is working great as well as xine. Only had to set the video to be xv in xine settings through the gui. Copied a ttf file for the font error message into ./mplayer it also works. I looked in the xine config file and didn't see a plugin path.
    I am kinda new at this..how would i go about doing this?

  11. #20
    Just Joined!
    Join Date
    Oct 2006
    Posts
    36

    I had a similar problem with dvd's

    I went to all the places you went to, no luck, but I found the Jem report for suse 10.0 and 10.1 that did the trick.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •