In order to get my gcj compiler to work I found I needed to install the GNU (i think it was gnu) CLASSPATH.

While trying to install CLASSPATH I recieved an error reporting that I needed a newer version of GTK+. Since my rpm manager wasn't able to update my gtk+ from 1.x.xx to 2.x.xx, I manually downlaoded it and attempted to install GTK+-2.6.7.

While trying to configure GTK:
./configure --prefix=/opt/gtk
I got the following error, looking for yet more dependencies:
checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 2.6.0    atk >= 1.0.1    pango >= 1.8.0... Package atk was not found in the pkg-config search path.
Perhaps you should add the directory containing `atk.pc'
to the PKG_CONFIG_PATH environment variable
No package 'atk' found

configure: error: Library requirements (glib-2.0 >= 2.6.0    atk >= 1.0.1pango >= 1.8.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can findthem.
It said it needed a newer version of glib (which my package managment also had trouble updating), it also said it needed a program called atk and a newer version of pango. So I installed all three of those, ran ldconfig and then tried the configure for gtk again. Still got the same error message, so I'm kind of stumped at the moment. For some reason configure doens't realize that I installed all these dependencies.

Any ideas are greatly apreciated!