Find the answer to your Linux question:
Results 1 to 9 of 9
The errors I get running make are qt-1.44/include/qregion.h:73:182: operator "defined" requires an identifier qt-1.44/include/qregion.h:73:182: ("xor" is an alternative token for "^" in C++) qt-1.44/include/qregion.h:73:185: missing '(' in expression make[1]: *** ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    7

    need to install qt-1.4 but can't due to compatibility issues


    The errors I get running make are
    qt-1.44/include/qregion.h:73:182: operator "defined" requires an identifier
    qt-1.44/include/qregion.h:73:182: ("xor" is an alternative token for "^" in C++)
    qt-1.44/include/qregion.h:73:185: missing '(' in expression
    make[1]: *** [dialogs/qfiledialog.o] Error 1

    I am hoping that I can use the legacy development tools to compile this properly but am having a hard time finding documentation on how the tools help such as
    compat-libstdc++ and
    compat-gcc-c++
    I thought these two would be used in some way of specifing the compiler to use.

    How do I get it to use the compatibility libraries?
    Will it even work?
    Is there another way of getting this legacy app to work?
    http://www.kmud.de/index.html?file=howto.html has instructions for compiling kmud which include the need for qt-1.44 and kde1 libraries to compile it.

    I am using FC3 which I update now and then. I am comfortable with whatever get thrown at me.
    I have all my files but have found that this compatibility issue with qt-1.44 is slowing me down.

    I am interested more in learning and accept that I might need to install an older os but then I will look at emulation or virtualization.

    Edit: I have edited this request a couple of times rearranging the content a little to hopefully get a reply.

  2. #2
    Just Joined!
    Join Date
    Jan 2005
    Posts
    7

    QT 1.4 install problems

    As I have had no response I am guessing I need to add more info.

    This problem with the QT libraries not installing is not just with my FC3 it has to do with the compilers change since qt-1.4 was made.

    How do I get around this. Someone anyone.

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    7

    Anyone Any auggestion

    Well this is the last time I ask.

    I have redone the layout of my orginal post to try and encourage replies, but so far I am just talking to myself. :(

    If anyone has any experience trying to get legacy apps to work on current distros I would appreciate your input. :)

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Okay, why is it you need such an old version of Qt? Will the newer versions not work? What errors do you get if you try to use the newer ones?

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  6. #5
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    I would recommend not using kmud. Use a superior client such as tintin++, kbtin, lyntin, ytin, or mudix or gmudix.

    Or, try the static binaries of kmud, I think I remember them offering them.

  7. #6
    Just Joined!
    Join Date
    Jan 2005
    Posts
    7
    Thanks Bryan,

    >Okay, why is it you need such an old version of Qt?
    Due to kmud being built on it. From the link above "Kmud 1.0 is based upon the KDE-Libraries from KDE1, which have been published by the KDE-Team in their latest version 1.1.2. These Libraries furthermore depend on the QT-Libraries version 1.4x."
    KDE1 seemed to install fine.

    >Will the newer versions not work?
    I have tried and they produce errors

    >What errors do you get if you try to use the newer ones?
    Let me check again . . . running configure gives back;

    checking for Qt... configure: error: Qt (>= 1.42 and < 2.0) (libraries) not found. Please check your installation!

    Before the error it all seemed ok. If there is a way around this I will give it a go.

  8. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    7
    Thanks Valan,

    >I would recommend not using kmud.
    Unfortunately I have yet to find a suitable client that has such a good mapper.

    >Use a superior client such as tintin++, kbtin, lyntin, ytin, or mudix or gmudix.
    I have seen many reviews for these clients and I am sure they are great. I currently use Tiny Fugue which I find satisfies my needs except for the mapper.

    >Or, try the static binaries of kmud, I think I remember them offering them.
    I tried the static binaries it ran and produced the following error when trying to connect to a mud

    BUG IN DYNAMIC LINKER ld.so: dynamic-link.h: 62: elf_get_dynamic_info: Assertion `! "bad dynamic tag"' failed!

    Trying to use the ping function of the client gives;

    GLIBC_2.3 not found
    GLIBC_PRIVATE not found
    GLIBC_2.1.1 not found
    GLIBC_2.2 not found

    So this led me to trying to install from source which has the difficulties as noted above.

  9. #8
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    Well then the only other thing I can think of is to download and install Qt 1 and the things for Kde 1 to get it working.

    Oh, I forgot to list TinyFuge. For a mapper, you might also look at The Grand MapMaker which is a standalone mapper written in Java. It may or may not be what you are looking for.

  10. #9
    Just Joined!
    Join Date
    Jan 2005
    Posts
    7
    Grand MapMaker is very neat but looks like it is for creating maps on the side with an option to convert the map you create into a ROM area map for use on ROM servers.

    If I cannot get kmud to work I might use this as I would like to have a map. One key benifit of kmud is that it has an automapper built in. From the screen shot of kmud the automapper is robust enough to compensate for the layout I have found in Torilmud.org.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •