Find the answer to your Linux question:
Results 1 to 10 of 10
After xmms finishes playing a song, it won't advance to the next one automatically. I have to select a new song or hit the next track button. I've messed with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Location
    Virginia, USA
    Posts
    32

    XMMS stops after every song


    After xmms finishes playing a song, it won't advance to the next one automatically. I have to select a new song or hit the next track button. I've messed with some settings, but I can't find a fis. What's going on?

  2. #2
    Linux Engineer LondoJowo's Avatar
    Join Date
    May 2005
    Location
    Richmond, TX
    Posts
    804
    Right click, options, and make sure "No Playlist Advance" is not selected.

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Location
    Virginia, USA
    Posts
    32
    It's not, and it does this with it on or off. Beep media player does the same thing, but Rythmbox and Amarok do not.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2006
    Location
    Athens/Greece
    Posts
    11
    i bit old post, but I have the same problem

    after every song xmms stops with the following msg



    im using eSound

  6. #5
    Just Joined!
    Join Date
    Oct 2006
    Location
    Athens/Greece
    Posts
    11
    i didnt have any luck with alsa neither with oss

  7. #6
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Generally when I get this message it means there's another program blocking audio output. Are any other programs running that might make use of the sound card?
    Registered Linux user #270181
    TechieMoe's Tech Rants

  8. #7
    Just Joined!
    Join Date
    Oct 2006
    Location
    Athens/Greece
    Posts
    11
    Quote Originally Posted by techieMoe
    Generally when I get this message it means there's another program blocking audio output. Are any other programs running that might make use of the sound card?
    I really don't know, i closed any app that may using the sound card (like gaim, opera etc.)

    the most logical explanation is this but i cant "prove" it

    btw, isn't that eSounds job ? (mixes several audio streams for playback by a single audio device)

  9. #8
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by Zeppelin
    I really don't know, i closed any app that may using the sound card (like gaim, opera etc.)

    the most logical explanation is this but i cant "prove" it

    btw, isn't that eSounds job ? (mixes several audio streams for playback by a single audio device)
    Have you looked at the running processes with top? Sometimes a program's window will close but there are still processes that belong to it running in the background. Are you running KDE or Gnome? KDE's sound system (which shows up as artsd in top) has been known to block things for me sometimes.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  10. #9
    Just Joined!
    Join Date
    Oct 2006
    Location
    Athens/Greece
    Posts
    11
    Im using gnome, i dont really think that the problem is caused by a program running in foreground


    Code:
    top
      PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                                       
     3608 zeppelin  15   0 42028  13m 8800 S 14.6  1.8   0:01.36 gnome-terminal                                                                
     2913 zeppelin  15   0  129m  67m  16m S  4.0  8.9   1:17.73 opera                                                                         
     3606 zeppelin  15   0  3956 2120 1592 R  2.3  0.3   0:03.26 esd                                                                           
     3179 zeppelin  15   0 77356  12m 5468 S  1.7  1.6   0:20.37 xmms                                                                          
     2837 zeppelin  15   0 98104  29m  12m S  1.0  3.9   0:17.58 beagled                                                                       
     2825 zeppelin  15   0 11980 6340 3296 S  0.3  0.8   0:04.59 compiz                                                                        
     2707 zeppelin  20   0 22380 5764 4856 S  0.0  0.7   0:00.11 gnome-session                                                                 
     2757 zeppelin  18   0  4288  496  256 S  0.0  0.1   0:00.00 ssh-agent                                                                     
     2760 zeppelin  18   0  2736  520  420 S  0.0  0.1   0:00.00 dbus-launch                                                                   
     2761 zeppelin  15   0 13084 1000  740 S  0.0  0.1   0:00.01 dbus-daemon                                                                   
     2768 zeppelin  18   0  7496 3820 1696 S  0.0  0.5   0:00.43 gconfd-2                                                                      
     2771 zeppelin  18   0  2540  592  480 S  0.0  0.1   0:00.00 gnome-keyring-d                                                               
     2773 zeppelin  15   0 33500 6952 5688 S  0.0  0.9   0:00.34 gnome-settings-                                                               
     2794 zeppelin  15   0 64796 5260 4044 S  0.0  0.7   0:00.08 gnome-power-man                                                               
     2796 zeppelin  15   0 74924  21m  12m S  0.0  2.8   0:01.83 gnome-panel                                                                   
     2798 zeppelin  18   0  104m  16m  11m S  0.0  2.2   0:01.07 nautilus                                                                      
     2802 zeppelin  18   0 38468 2636 1976 S  0.0  0.3   0:00.10 bonobo-activati                                                               
     2805 zeppelin  15   0 11168 3056 2584 S  0.0  0.4   0:00.01 gnome-vfs-daemo                                                               
     2807 zeppelin  20   0 34020 6872 5728 S  0.0  0.9   0:00.02 eggcups                                                                       
     2809 zeppelin  18   0 14100 4404 3768 S  0.0  0.6   0:00.00 bluetooth-apple                                                               
     2810 zeppelin  18   0 22136 4152 3276 S  0.0  0.5   0:00.00 gnome-volume-ma                                                               
     2824 zeppelin  17   0 24568  12m 7660 S  0.0  1.7   0:00.15 puplet                                                                        
     2826 zeppelin  15   0 17536 8004 5300 S  0.0  1.0   0:01.66 gnome-window-de                                                               
     2836 zeppelin  15   0 65000 8292 7032 S  0.0  1.1   0:00.05 nm-applet                                                                     
     2839 zeppelin  15   0 14900 4060 3464 S  0.0  0.5   0:00.02 pam-panel-icon                                                                
     2852 zeppelin  17   0  5908 1764 1472 S  0.0  0.2   0:00.00 escd                                                                          
     2853 zeppelin  20   0     0    0    0 Z  0.0  0.0   0:00.00 netstat <defunct>                                                             
     2873 zeppelin  19   0 77712  10m 7876 S  0.0  1.3   0:00.16 gweather-applet                                                               
     2875 zeppelin  15   0 67376  10m 7872 S  0.0  1.4   0:01.34 wnck-applet                                                                   
     2876 zeppelin  15   0 28140 8868 6700 S  0.0  1.1   0:00.15 clock-applet                                                                  
     2878 zeppelin  15   0  2444  836  732 S  0.0  0.1   0:00.00 mapping-daemon                                                                
     2882 zeppelin  15   0  2660 1176  952 S  0.0  0.2   0:00.01 gam_server                                                                    
     2891 zeppelin  15   0 22568 6332 5368 S  0.0  0.8   0:00.09 notification-ar                                                               
     2893 zeppelin  15   0 67856  10m 8300 S  0.0  1.4   0:00.35 stickynotes_app                                                               
     2895 zeppelin  15   0 67728  10m 8064 S  0.0  1.4   0:00.13 mixer_applet2                                                                 
     2897 zeppelin  15   0 66588 9404 7040 S  0.0  1.2   0:02.13 netspeed_applet                                                               
     2899 zeppelin  15   0 22660 6704 5708 S  0.0  0.9   0:00.08 multiload-apple                                                               
     2949 zeppelin  15   0 15928 1656  984 S  0.0  0.2   0:00.34 gnome-screensav                                                               
     3029 zeppelin  30  15 49536  21m 8612 S  0.0  2.8   0:51.95 beagled-helper

  11. #10
    Just Joined!
    Join Date
    Mar 2005
    Location
    Seattle, WA
    Posts
    7
    I was just having this problem after upgrading versions of Fedora. I installed the xmms-pulse package for the XMMS PulseAudio plugin, then I changed the XMMS preferences to use it. Fixed the problem for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •