I believe I have downloaded all of the necessary files...see:

pyxf86config-0.3.19-4
pyOpenSSL-0.6-1.p24.4
gnome-python2-gtkhtml2-2.10.0-2.1
dbus-python-0.33-3
pygtk2-2.6.2-0.fc4.1
python-devel-2.4.1-2
gnome-python2-bonobo-2.10.0-1
python-2.4.1-2
python-urlgrabber-2.9.6-1
python-sqlite-1.1.6-1
pyorbit-2.0.1-4
gnome-python2-canvas-2.10.0-1
pyparted-1.6.9-3
pygtk2-libglade-2.6.2-0.fc4.1
gnome-python2-gconf-2.10.0-1
python-elementtree-1.2.6-4
PyXML-0.8.4-3
gnome-python2-gnomevfs-2.10.0-1
gnome-python2-extras-2.10.0-2.1
pygtk2-devel-2.6.2-0.fc4.1
gnome-python2-2.10.0-1
libxml2-python-2.6.20-1.FC4
pyorbit-devel-2.0.1-4
rpm-python-4.4.1-22
python-ldap-2.0.6-4
and I have all of the Orbit (all 4) files.

But, when I try to ./configure, i keep getting this error:

checking for glib-2.0 gtk+-2.0 gdk-pixbuf-2.0 pygtk-2.0 >= 2.4.0... Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found

configure: error: Library requirements (glib-2.0 gtk+-2.0 gdk-pixbuf-2.0 pygtk-2.0 >= 2.4.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
Now, I looked and I can see glib-2.0 in my /usr/lib/pkconfig but not gtk+-2.o(i know i have it, because i have GIMP) as well as pixbuf2.0(isn't that GIMP-related, too?).

Anyhoo, I'm at a loss. Little help, please?