hi

i installed debian from knoppix on my hardisk then changed to the unstable version instead of the knoppix 2.4....
and now when in 'apt-get install emacs21' it installs well.. but when i open it, i get the following warning...

Warning: Cannot convert string "-*-courier-medium-r-*-*-*-120-*-*-*-*-iso8859-*" to type FontStruct
Warning: Unable to load any usable ISO8859 font
Warning: Cannot convert string "-*-helvetica-medium-r-*--*-120-*-*-*-*-iso8859-1" to type FontStruct
Warning: Unable to load any usable ISO8859 font
Warning: Unable to load any usable ISO8859 font

and then emacs opens with all BOXED characters.. the kind of you would see when, say, you open a .doc file using wordpad on windows...
then i tried to install xemacs hoping that this would be better. this also installs but it doesnot run at all and says fatal error (11)

a similar kind of error occured when i tried to install the yahoo messenger from their site - font rpoblem and it goofes up....

kindly help