Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Emacs is there but wont run!

    I did install my linux system with all features for emacs. But when I run "emacs"
    alone, it says "bad or unrecognized command"
    command as if emacs was not on my system.
    At first, I though it was a matter of putting the executable of emacs in the path variable so
    I can run it from whatever path.
    But that was not the issue: I did a search of emacs files on my system, and found a lot of emacs related datas.
    But no emacs executable under /usr/bin or /bin. The only emacs file I found and that is closed to the emacs
    executable si a file called "emacsclient". But when running it, it asks for the emacs server! I tried
    all of the other emacs files, but there's no emacs server or any file that did execute emacs!
    Redhat 4.2 kernel 2.0.30

  2. #2
    Linux Guru
    Join Date
    Apr 2003
    London, UK
    then you have 2 choices:
    1) Put the redhat CD in the drive, locate the emacs RPM and install it.
    2) and download an updated emacs and libaries.


  3. #3
    Linux Engineer
    Join Date
    Mar 2003
    I assume your logged in as root and with roots profile?

    \"Keep your friends close and your enemies even closer\" from The Art of War by Sun Tzu\"

  4. $spacer_open
  5. #4
    Yes Dan

  6. #5
    try typing emacs and hit tab twice. What do you get?

    i get this:
    kriss@wilber:~$ emacs
    emacs emacs-21.2-with-x11 emacsclient
    emacs-21.2-no-x11 emacs-21.3.50
    kriss@wilber:~$ emacs

    So, lets say that you just got emacs-21.2-no-x11 you could just set up an alias like alias emacs='emacs-21.2-no-x11' so everytime you run "emacs" it really runs "emacs-21.2-no-x11".

    Hope this helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts