Find the answer to your Linux question:
Results 1 to 4 of 4
i am really frustated with this...i still couldnt set the environment variable... i need to set the PATH by my jdk; i have tried the following code and put it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    44

    still in problem with setting environment var


    i am really frustated with this...i still couldnt set the environment variable... i need to set the PATH by my jdk;

    i have tried the following code and put it at the beginning of the .bashrc file and also tried this code on the shell but yet no help.
    Code:
    export PATH=$PATH:/usr/java/JDK-1.5.0_04/bin/
    still it tries to compile with gcj instead of taking the java command from the installation directory.

    in the shell i have also tried with the setenv command by putting
    Code:
    setenv PATH /usr/java/JDK-1.5.0_04/bin/
    setenv CLASSPATH $JMFHOME/lib/jmf.jar:.:${CLASSPATH}:
    but it reports with 'command not found error'
    now tell me what to do...

  2. #2
    Linux User
    Join Date
    Aug 2005
    Location
    Peterborough, UK
    Posts
    379
    It sounds like you've got to a point half-way through this tutorial. Try following the remaining steps, and see if that works...
    \"I am, after all,\" said Pooh, \"a bear of very little brain.\"
    MY PC: Athlon XP64 3000+ on a Asus K8V-X mobo w/1GB of non-descript RAM. AGP - GeForce 2 MX400. PCI - Creative Live! 5.1 soundcard. 140 GB and 120 GB SATA WD drives.

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    44

    how to set the class path

    hey now i have succeeded setting environment variables. but still dont know how to set the Classpath...

    can you tell? say i have a api at /root/software/jmf/jmf.jar
    how can i include it into the class path?

    please dont tell me to do anything into the .bashrc file. i have tried it already. it didnt work!

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Sep 2005
    Location
    CZ
    Posts
    164
    OK, now try setting it within .bash_profile :P

    If you want to try manually set the variable do:
    VAR=$VAR:"your value"
    echo $VAR


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •