Find the answer to your Linux question:
Results 1 to 4 of 4
Sorry, wasn't sure if this post should be in the servers or apps group. Anyway, I've installed a SuSE Enterprise server (v9) as a new proxy server running Squid. However, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Location
    UK
    Posts
    67

    SSHd problem


    Sorry, wasn't sure if this post should be in the servers or apps group.

    Anyway, I've installed a SuSE Enterprise server (v9) as a new proxy server running Squid. However, I can't SSH into the machine as root or anyone else. SSH is running as it prompts for the username and then password. The "allow root access" option is set to yes, but it won't allow root access OR any other accounts such as my own.

    I've looked at an sshd_config file from another machine (but a different os unfortunatly) and the file looks pretty similar...

    Any thoughts?

    tnx, Nick

  2. #2
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    1. Are you sure sshd is running?
    Code:
    rcsshd status
    2. On the sshd server machine, try
    Code:
    netstat -atun
    Is port 22 open/listening?

    3. Did you open port 22 in your SuSEfirewall2?

    4. What type of machine / client are you trying to connect from?

    5. Immediately after trying to connect, take a look at
    Code:
    tail -20 /var/log/messages
    on the sshd server machine. What does it tell you?

    P.S. You should disable PermitRootLogin in your sshd_config anyway. That is a bad practice to allow it.

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Location
    UK
    Posts
    67
    pam_unix2 bad username was the entry in messages.

    Otherwise, yes, SSH is running and SuSE Firewall is disabled as the machine is behind a Cisco Pix. I'm only allowing root access to save me a walk to the server room. Once it's running I'll deny it again!

    Cheers,

    Nick

  4. #4
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    That's a weird symptom. Even root gets the "bad username" message from PAM?

    For the short term you can try changing the parm
    Code:
    UsePAM yes
    to
    Code:
    UsePAM no
    and turn on password authentication (another parm in the same sshd_config file) to see if you can get through.

    For the long term you probably do want to use PAM, so even if that temporarily solves the problem it leaves you in a tough place.

    Another thought: What type of client are you connecting from? SSH clients can have a lot of flaky issues themselves. To try to eliminate that as a possibility, try connecting from another *nix box that is able to act as a client successfully on other servers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •