That message most likely means you did not su - to the root user before attempting to install packages.. you must be root in order to run apt and have it succesfully install anything.