Find the answer to your Linux question:
Results 1 to 7 of 7
when I start xawtv, for record from webcam, in the terminal: WARING: v4l-conf is compiled without DGA support. v4l-conf had same trouble, trying to continue anyway. and then the system ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    9

    problem with xawtv


    when I start xawtv, for record from webcam, in the terminal:

    WARING: v4l-conf is compiled without DGA support.
    v4l-conf had same trouble, trying to continue anyway.

    and then the system crash. Why??
    Please Help me

  2. #2
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    Ciao bello, benvenuto sui forum, magari se traduci il titolo ti potremmo aiutare .

    At first sight, I'd say: recompile video4linux with DGA support. So rebuild your kernel and check the video4linux options in the config.
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  3. #3
    Just Joined!
    Join Date
    Sep 2005
    Posts
    9
    ok, but I dont know how to compile video4linux with support DGA. how to do it?
    sorry for my bad english

  4. #4
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    No problem . You need to recompile your kernel basically; in the graphical configuration, you'll find a video4linux entry, if the problem report you had is correct, there should be a DGA option you can enable.
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  5. #5
    Just Joined!
    Join Date
    Sep 2005
    Posts
    9
    uhm uhm
    how to start the graphical configuration of the kernel?

  6. #6
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    Download the kernel sources. Be sure they match your current kernel. To find out which kernel you are using, do $ uname -r. Then look for the kernel sources, download them and install them.
    Then do
    Code:
    $ su
    # cd /usr/src/linux-[kernel version]
    Normally there should be a default configuration file, that comes with the kernel source package. It's named .config (a hidden file). Check if it's there:
    Code:
    # ls -a
    If yes, ok. Then type
    Code:
    # make xconfig
    or
    Code:
    # make gconfig
    Then a graphical interface will pop up in which you can configure the kernel options. Look for the video4linux entry and check the options. After that, save and quit the graphical configuration tool. Then do
    Code:
    # make && make modules_install
    After that is done, install the kernel and system map to /boot and add it to your boot loader (lilo or GRUB).

    Note: this only applies when you're using a 2.6.x kernel.
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  7. #7
    Just Joined!
    Join Date
    Nov 2006
    Posts
    1

    Angry Omfg

    <rant>

    Words simply cannot describe how angry i was when i came across this useless thread via google but i'm going to try, lets just distill the above conversation shall we?

    noob: hey guys i love this linux thing but i've got a teeny weeny problem any ideas?
    hax0r: hey there little guy you need to recompile the kernel blah blah blah...
    noob: recombobulate the what?!?!?!, whatever dude i'm reinstalling windows.

    10 PRINT BORROMINI = TOOL
    20 GOTO 10

    For the love of linus somebody purge this from google's cache.
    </rant>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •