Recently I've tried to upgrade to iptables 1.3.4 from 1.3.3. The first thing I tried was using the upgrade file available from their site,
filename: patch-iptables-1.3.3-1.3.4. I had no idea how to run that patch and there was no RPMs available since this version is only about a week or so old. So then I decided to install it using make, which I'm usually very unlucky with. So I ran make as instructed in the INSTALL file in the iptables-1.3.4 tar file:

"FOLLOW THESE STEPS:

1) Make the package.
% make KERNEL_DIR=<<where-you-built-your-kernel>>

2) Finally, you need to to install the shared libraries, and the binary:
# make install KERNEL_DIR=<<where-you-built-your-kernel>>"

when I did the first step I got this output:

# make KERNEL_DIR=/usr/src/linux
Making dependencies: please wait...
Something wrong... deleting dependencies.
make: *** [linux/autoconf.h] Error 1

I have no idea what this error means but I checked the file it mentioned and it isnt in my kernel source folder (autoconf.h). So I downloaded the latest kernel and checked if my version of make was up to date. Then I tried the command again and it gave me the same error message.

If these details help I was using kernel source linux-2.6.14 from
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/ and I am currently running SuSE Linux 10.0 Retail.

Any help would be apprectiated,
n00b mikfig