Find the answer to your Linux question:
Results 1 to 7 of 7
Hi everyone, I'm sorry if I'm missing something obvious, but I can't get to start OOo 2.0 . I am running Mandriva LE2005 / KDE , linux is still completely ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Location
    France
    Posts
    17

    OpenOffice 2.0 won't start


    Hi everyone,

    I'm sorry if I'm missing something obvious, but I can't get to start OOo 2.0 .
    I am running Mandriva LE2005 / KDE , linux is still completely new to me.
    OOo 1.1.4 is already installed on the machine (not uninstalled yet because I need it all the time).

    I downloaded the package from OOo.org, unpacked and run all of the OpenOffice.org base and components rpms, plus the Mandriva menu rpm. No problem during installation.
    The nice new icons are now present in the menus... but when I click them I only get the "starting OOo" button showing in the taskbar and absolutely nothing happens (no CPU usage, no HD use) . Nothing crashes, though.

    I tried uninstalling / reinstalling the rpms, also with the Mandriva Control Center. No change. Did some searches on the web but found no similar problem.

    Does anyone have any idea that could help me out ? Should I maybe uninstall OOo 1.1.4 first (I'm reluctant to do this) ?

    Many thanks in advance !

    Greetings,

    Olivier.

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211

    Solution: DRI

    I can only say I had the same problem on Debian Sarge with OpenOffice 2.0.
    I installed it after converting rpms to debs with alien.

    But, exact same problem: show Starting Open Office... then nothing.

    With the console, I did
    Code:
    whereis soffice
    It showed /usr/bin/soffice

    And then I opened that file from the terminal, it opened in the base office, then if a open a document, or try to create a new one, I have:

    Code:
    /usr/bin/soffice: line 224:  3627 Segmentation fault      "$sd_prog/$sd_binary" "$@"
    Those numbers changes from time to time.

    "Segmentation fault", so it seems related to DRI...

    got the solution... edit you xorg.conf so to add something like this (probably this section is already there, at the end of the file):
    Code:
    Section "DRI"
            Group "users"
            Mode 0660
    EndSection
    Then add yourself to /etc/group in the "users"

    In /etc/group :
    Code:
    users:x:100:yourself
    Of course you enter your username, and not "yourself",


    I found the solution here: http://archlinux.org/pipermail/arch/...er/003011.html

    Works!
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Location
    France
    Posts
    17

    doesn't seem to work

    Thank you for your help, antidrugue.

    I tried to do exactly what you said... Had to login as root, which wasn't reassuring (I am quite a newbie and editing seemingly important files makes me shiver a bit).

    I added the section in the xorg.conf file (it wasn't here already) and then edited the etc/group file to add myself.

    But..... problem unsolved. Could it be related to the fact that "whereis soffice " doesn't give any result for me ?

    Thanks anyway;

    Olivier.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    OK then.

    It could be that you don't have "Load "dri"" in your /etc/xorg.conf

    At the begining...
    Code:
    Section "Module"
            Load    "bitmap"
            Load    "dbe"
            Load    "ddc"
            Load    "dri"
    And
    Code:
    Section "DRI"
            Group   "users"
            Mode    0660
    EndSection
    ... at the end.


    so /etc/group:
    Code:
    users:x:100:yourself
    Once you have this... should work. Once again, you have Mandriva and I have Debian, it is possible that things are different.

    Where did you find OpenOffice? From the www.openoffice.org ? Or is it a package from Mandriva?[/code]
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #5
    Just Joined!
    Join Date
    Aug 2005
    Location
    France
    Posts
    17

    whops !

    Woooo

    did this and it thwarted X-Window upon reboot :

    Code:
    glXExtensionInt: AddExtensions failed
    I had to try and choose another graphic device (I was on "Radeon (fglrx)" and had to switch to "Radeon 8500). With crappy graphics (could barely read text on the screen) I managed to restore a bizarre backup of xorg.comf.
    Rebooted couple of times, messed around not really knowing (seeing !) what I was doing, and normal graphics are back.
    The xorg.conf now says:
    Code:
    Section "Module"
        Load "dbe" # Double-Buffering Extension
        Load "v4l" # Video for Linux
        Load "extmod"
        Load "type1"
        Load "freetype"
        Load "synaptics"
        Load "/usr/X11R6/lib/modules/extensions/libglx.a"
        Load "bitmap"
        Load "dbe"
        Load "ddc"
        Load "glx" # 3D layer
    EndSection
    So it seems that the
    Code:
    Load "dri"
    has been replaced by the
    Code:
     Load "glx"
    and I don't know how.
    Should I retry ? What is a safe way to do it (an easy way to recover the original file without X-Window...) ?

    Thanks anyway. If I'm wasting your time I apologise...

    Olivier.

  7. #6
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Hehe. We're having a lot of fun here!

    Yes, I forgot to say one thing: things don't always go as planned... so make backups!

    Prior to making any change to xorg.conf...
    Code:
    cd /etc/X11
    sudo cp xorg.conf xorg.conf_old
    Maybe you have a different version of OpenOffice... which doesn't use DRI... (i don't believe it though)

    Of course we have different system, but just for reference, here is my xorg.conf, it will be simpler like that (I made it lighter by taking off the comments, for your eyes only):
    Code:
    Section "Files"
    	FontPath	"unix/:7100"		
    	FontPath	"/usr/lib/X11/fonts/misc"
    	FontPath	"/usr/lib/X11/fonts/cyrillic"
    	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
    	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
    	FontPath	"/usr/lib/X11/fonts/Type1"
    	FontPath	"/usr/lib/X11/fonts/CID"
    	FontPath	"/usr/lib/X11/fonts/100dpi"
    	FontPath	"/usr/lib/X11/fonts/75dpi"
    EndSection
    
    Section "Module"
    	Load	"bitmap"
    	Load	"dbe"
    	Load	"ddc"
    	Load	"dri"
    	Load	"extmod"
    	Load	"freetype"
    	Load	"glx"
    	Load	"int10"
    	Load	"record"
    	Load	"type1"
    	Load	"v4l"
    	Load	"vbe"
      	SubSection "extmod"
        		Option "omit xfree86-dga"
      	EndSubSection
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"keyboard"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc104"
    	Option		"XkbLayout"	"ca"
    	Option		"XkbVariant"	"fr_ca"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"		"/dev/input/mice"
    	Option		"Protocol"		"ImPS/2"
    	Option		"Emulate3Buttons"	"false"
    	Option		"ZAxisMapping"		"4 5"
    EndSection
    
    Section "Device"
    	Identifier	"ATI"
    	Driver		"fglrx"
    	BusID		"PCI:1:0:0"
      		Option "VideoOverlay" "on"
      		Option "OpenGLOverlay" "off"
      		Option "UseInternalAGPGART" "no"
    EndSection
    
    Section "Monitor"
    	Identifier	"Generic Monitor"
    	Option		"DPMS"
    	HorizSync          30-96
    	VertRefresh	50-160
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"ATI"
    	Monitor		"Generic Monitor"
    	DefaultDepth	24
    	SubSection "Display"
    		Depth		24
    		Modes		"1024x768"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Generic Keyboard"
    	InputDevice	"Configured Mouse"
    EndSection
    
    Section "DRI"
    	Group	"users"
    	Mode	0660
    EndSection
    So, you have both "glx" and "dri"

    Once, you have "dri" loaded, you try to start OpenOffice from the terminal, as root. So that way we are sure that even if /etc/group is not set up correctly it will work.

    You don't have soffice? You are right about this one, that means that you have installed OpenOffice from your Mandriva repository and not from the site (www.fr.openoffice.org).

    So, in your case the executable is "ooffice"
    Code:
    whereis ooffice
    Just to make sure we are in the right direction, start ooffice from the Konsole:
    Code:
    ooffice -writer
    for example.

    And send me the error message...

    Que la force soit avec toi!
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  8. #7
    Just Joined!
    Join Date
    Aug 2005
    Location
    France
    Posts
    17
    Allright, allright.

    I started with typing
    Code:
    ooffice -writer
    and... landed on OOo 1.

    So I took a deep breath and uninstalled the old version... reboot... some cleanup (including xorg.comf) ... install OOo 2 fails... clean up... try to install it via the Mandrake Installation Center... a few more tries and...

    It works. Whew ! Linux is really great but there are times I miss the good'ol setup.exe.


    Now I have bizarre error messages popping up when opening documents. Also (and worse) the antialias on the document (not the menus) is gone.
    But... must keep going on my courseworks. I'll work on the matter in a little time from now. All I wanted is have it working, absolutely.

    In the meantime... Thank you antidrugue ! Your friendly help is very appreciated.

    I'm back to work with stylish new buttons and logo. = )

    Olivier.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •