Find the answer to your Linux question:
Results 1 to 2 of 2
Hi All.. Today I was trying to install Gaim (gaim-1.5.0-0rh9.i386.rpm) on my notebook which is having CentOS 4.2 installed. When I run the RPM installtion I got the failed dependencies ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Location
    India
    Posts
    14

    Installation Failed


    Hi All..

    Today I was trying to install Gaim (gaim-1.5.0-0rh9.i386.rpm) on my notebook which is having CentOS 4.2 installed. When I run the RPM installtion I got the failed dependencies error..

    [root@ksnb]# rpm -ivh gaim-1.5.0-0rh9.i386.rpm
    error: Failed dependencies:
    libpspell-modules.so.1 is needed by gaim-1.5.0-0rh9.i386
    libpspell.so.4 is needed by gaim-1.5.0-0rh9.i386
    Then I downloded the RPM (pspell-0.12.2-16.1.i386.rpm) and tried installing this, but then there was another error..

    [root@ksnb]# rpm -ivh pspell-0.12.2-16.1.i386.rpm
    warning: pspell-0.12.2-16.1.i386.rpm: V3 DSA signature: NOKEY, key ID 025e513b
    Preparing... ########################################### [100%]
    file /usr/bin/pspell-config from install of pspell-0.12.2-16.1 conflicts with file from package aspell-0.50.5-3.fc3
    So now I am stuck what to do as aspell is already installed there and I can not remove this as it required by lots of other applications..

    [root@ksnb]# rpm -qa | grep spell
    aspell-en-0.51-11
    aspell-0.50.5-3.fc3
    gtkspell-2.0.7-2
    openoffice.org-spellcheck-2.0.0-3
    gnome-spell-1.0.5-9
    [root@ksnb]# rpm -e aspell
    error: Failed dependencies:
    libaspell.so.15 is needed by (installed) php-4.3.9-3.8.i386
    libaspell.so.15 is needed by (installed) gtkspell-2.0.7-2.i386
    libaspell.so.15 is needed by (installed) gnome-spell-1.0.5-9.i386
    libaspell.so.15 is needed by (installed) kdelibs-3.3.1-3.11.i386
    libaspell.so.15 is needed by (installed) gedit-2.8.1-4.i386
    libpspell.so.15 is needed by (installed) php-4.3.9-3.8.i386
    aspell >= 0.50 is needed by (installed) aspell-en-0.51-11.i386
    So now how to proceed : ?. Any suggestions..

  2. #2
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    Luton, England, UK, Earth
    Posts
    639
    Try using a package manager, like SMART, it will handle the package dependencies for you, and save you from dependency hell.

    Here ya hol; http://labix.org/smart

    I think that is the right site.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •