Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, Until yesterday, I was able to listen to mp3s but not CDs. So, I downloaded the Cdread plugin and installed it. Somebody suggested on a newsgroup yesterday that I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2003
    Posts
    13

    xmms problems


    Hi,
    Until yesterday, I was able to listen to mp3s but not CDs. So, I downloaded the Cdread plugin and installed it. Somebody suggested on a newsgroup yesterday that I might have to use the correct link for the default device, for the plugin to function properly . After doing that (the link I am currenly using is "/dev/scsi/host0/bus0/target0/lun0/cd"), I am atleast able to see the playlist now (which wasn't the case before). However, now I am not even able to play mp3s. Every time I try to play, this is the message I get :

    Please check that :

    1. You have the correct output plugin selected
    2. No other program is blocking the soundcard
    3. Your soundcard is configured properly

    Choice 1 cannot be the problem as I have checked the OSS as my output plugin, which was working fine till yesterday. Even choice 2 I think is unlikely as there doesn't seem to be any other program which is blocking the soundcard. This is what I think has happened. The free version of the oss driver functions only for three hours after executing the 'soundon' command. If you want the driver to function again, you have to run the command 'soundoff' and then 'soundon' again. However, I am not able to execute the command 'soundoff'. These are the error messages I get :

    emu10k1x: Device or resource busy
    ac97: Device or resource busy
    pnp: Device or resource busy
    soundbase: Device or resource busy
    sndshield: Device or resource busy

    Can somebody help me out with this ?

    Regards,

  2. #2
    Just Joined!
    Join Date
    Sep 2003
    Posts
    13

    am getting sound!

    Hi,
    Since I was not able to run the command 'soundoff', I tried logging out and then starting a different window manager. I read on tldp.org that sometimes window managers like kde (which is what I was using) have a tendency to "hold on" to the sound modules (whatever that means!). It further said that I should close all my windows and then try to unload the module. Since that wasn't working out (or probably I didn't know how to do it), I tried what I did. From a different window manager (IceWm), I was able to execute the command 'soundoff' easily. Now, I am able to play CDs, but however the sound quality is horrible. However, the audio quality is much better when I play mp3s.
    Incidentally, does anybody know if the Soundblaster Live! soundcard (the one shipped with the Dell machines) is supported under ALSA in Mandrake 9.1 ? In a different forum, somebody replied that in Mandrake 9.2, it is. However, I am not sure if that is also the case in Mandrake 9.1

    Regards,

    Sanjiv

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •