Find the answer to your Linux question:
Results 1 to 4 of 4
I looked around and couldn't find an answer to this question... I have tried compiling this program however I can ./configure fine but when I make install it gets to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    1

    Problem building Xchat 2.6.0


    I looked around and couldn't find an answer to this question...

    I have tried compiling this program however I can ./configure fine but when I make install it gets to this point. These are the last few lines of my output in the Terminal.

    I'm running Suse 10.0, KDE Enviornment and I have installed the GCC packages from the CDs.

    gcc -g -O2 -Wall -pipe -Wno-pointer-sign -funsigned-char -o xchat about.o ascii.o banlist.o chanlist.o chanview.o dccgui.o editlist.o fe-gtk.o fkeys.o gtkutil.o ignoregui.o menu.o maingui.o mmx_cmod.o notifygui.o palette.o pixmaps.o plugingui.o rawlog.o search.o servlistgui.o setup.o textgui.o urlgrab.o userlistgui.o xtext.o -Wl,--version-script -Wl,./../version-script -Wl,--export-dynamic ../common/libxchatcommon.a -L/usr/X11R6/lib -L/opt/gnome/lib /opt/gnome/lib/libgtk-x11-2.0.so /opt/gnome/lib/libgdk-x11-2.0.so /opt/gnome/lib/libatk-1.0.so /opt/gnome/lib/libgdk_pixbuf-2.0.so /opt/gnome/lib/libpangocairo-1.0.so /opt/gnome/lib/libpangoft2-1.0.so /opt/gnome/lib/libpango-1.0.so /usr/lib/libcairo.so /opt/gnome/lib/libgobject-2.0.so /opt/gnome/lib/libgmodule-2.0.so /usr/lib/libfontconfig.so /usr/lib/libfreetype.so /usr/lib/libexpat.so -lXrender -lX11 -lXext -lpng12 -lz /usr/lib/libglitz.so -lm -ldl /opt/gnome/lib/libglib-2.0.so
    /usr/lib/gcc/i586-suse-linux/4.0.2/../../../../i586-suse-linux/bin/ld: Invalid version tag `EXPORTED'. Only anonymous version tag is allowed in executable.
    collect2: ld returned 1 exit status
    make[2]: *** [xchat] Error 1
    make[2]: Leaving directory `/home/cpiehler/Xchat/xchat-2.6.0/src/fe-gtk'
    make[1]: *** [install-recursive] Error 1
    make[1]: Leaving directory `/home/cpiehler/Xchat/xchat-2.6.0/src'
    make: *** [install-recursive] Error 1

    Thank you.

    -CW55

  2. #2
    Banned
    Join Date
    Jul 2004
    Posts
    947
    looks fine to me
    just

    Code:
    make install

  3. #3
    Just Joined!
    Join Date
    Dec 2005
    Posts
    1
    i have the same problem....it just wont install it.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2006
    Posts
    1

    Lightbulb Solution!

    I had the same problem and I fixed it by doing this:
    1. Open up src/version-script in emacs or equivalent
    2. Completely remove the part that says "EXPORTED" (but leave the curly brace)
    3. cd to the root of the xchat source tree
    4. run make clean (important)
    5. run make
    6. run su -c "make install" and type in your root password

    Hope this helps

    -dandaman32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •