Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Hi I am using mandrake 10.1 and when trying to play a cd the tracks show up and the counter ticks by but no sound in KsCD. I have checked ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2005
    Posts
    11

    no cd rom audio sounds


    Hi I am using mandrake 10.1 and when trying to play a cd the tracks show up and the counter ticks by but no sound in KsCD. I have checked kmix and configured that and volume is up etc. Sound works on the xp dual boot so card and cd drive work ok. The "use digital playback button" is unchecked and I can't get it highlighted to check it. Could this be the problem? and how can I check this box? also the drives (2 cd-roms) are mounted should this make a difference.
    Any help really appreciated.
    Thanks in anticipation
    Andy

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Do you have an audio cable running between your cd drive and soundcard/onboard sound? If not KsCD will not play the CD's audio, if you want it to play CD's you can do to things:

    Get a cable to go between your Cd ard soundcard.
    OR
    Use a pragram like Xine which will let you play it all through the IDE cable, like is done in windows.

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    do you get sound with other things like mp3's or embedded video in browser? If so then cable probably is your problem if not then its your mixer settings most likely. I personally like alsamixer because its easy but there are many others. If you try alsamixer just type: alsamixer on the command line and make sure that at least "master" and "pcm" are unmuted. Unmute by pressing M.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2005
    Posts
    11

    Still having trouble!

    Hi I can only get sound via the nvidia sound card on the motherboard but I want to use the soundblaster live card which I have now connected the cable to the cdrom drive so if I can configure this card I think it will work but I can't seem to get this card to play any sounds at all. How do I get alsamixer? I am new to linux so can you be more specific (idiots guide!) I typed alsamixer into command run from start menu and nothing happened! How do I get to the command line? and do I need to type in any symbols as well?
    Thanks
    Andy

  6. #5
    Just Joined!
    Join Date
    Nov 2005
    Posts
    11

    Update from previous message

    I have now got the sound blaster to work and it is connected to cd rom but KsCD will still not play but shows album track and timer. Frustrating! Happy to try alsamixer but need a bit more guidance on how to get it.
    Many thanks
    Andy

  7. #6
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    To try alsamixer, look through the terminals for something like konsole or xterm, if you can't find these, try running these in the `run` box, and once you have them open type
    Code:
    alsamixer
    .
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  8. #7
    Just Joined!
    Join Date
    Nov 2005
    Posts
    11

    alsamixer

    I have found alsamixer but all that comes up is a load of scales, how do I actually go about using it to play audio cd's?
    No luck with KsCD whatever I do but I have other sounds and KsCD shows the tracks etc and the counter works but no music.
    Any help appreciated
    Andy

  9. #8
    Linux Enthusiast deltaflyer's Avatar
    Join Date
    May 2005
    Posts
    577
    use the arrow keys to move around,left/right arrows move you from setting to setting,up/down arrow increase or decrease

    andy
    SLOMO: acer extensa 5235 2.2ghz,2gb ram 160gb hdd wireless
    SPEEDY: homebrew desktop,Amd x2 dualcore,2gb ram,500gb +1tb( 2x500gb) hdd suse 11.3,32mb fibreline
    registered linux user #401845

  10. #9
    Just Joined!
    Join Date
    Nov 2005
    Posts
    11

    cd rom probs

    When I click on the cd rom icon another box comes up and says HDC input/output error, can't read superblock, please check disk is entered correctly. So when I use alsamixer all I get is the scales which I can adjust but I think the problem must be with the installation of the drive. This drive works perfectly on XP dual boot so I don't think its a hardware issue. Also when using KsCD it obviously recognises the disk but have no sound. I have reinstalled mandrake 10.1 but problem still exists.
    I really like Linux but I am quite a novice and slowly becoming a convert but getting frustrated!
    Thanks
    Andy

  11. #10
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    as far as alsamixer just make sure master and pcm are unmute. Toggle mute /unmute by pressing M.

    As far as your cd-rom drive we need to see your fstab entries. This is the file that controls devices. You will find it here: /etc/fstab

    use an editor (nano, vim, emacs, .......) and then paste what you have in there here.

    You can also read fstab manual: man fstab

    or look online.

    here is my fstab
    Code:
    # noatime turns off atimes for increased performance (atimes normally aren't 
    # needed; notail increases performance of ReiserFS (at the expense of storage 
    # efficiency).  It's safe to drop the noatime options if you want and to 
    # switch between notail / tail freely.
    #
    # See the manpage fstab(5) for more information.
    #
    
    # <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>
    
    # NOTE&#58; If your BOOT partition is ReiserFS, add the notail option to opts.
    /dev/hda1               /boot           ext2            noauto,noatime  1 1
    /dev/hda3               /               jfs             noatime         0 1
    /dev/hda2               none            swap            sw              0 0
    /dev/hda4               /kafka          jfs             noatime         0 0
    /dev/cdroms/cdrom0      /mnt/cdrom      iso9660         noauto,ro,user  0 0
    #/dev/fd0               /mnt/floppy     auto            noauto          0 0
    none                    /proc/bus/usb   usbfs           defaults        0 0
    # NOTE&#58; The next line is critical for boot!
    none                    /proc           proc            defaults        0 0
    none                    /dev/shm        tmpfs           nodev,nosuid,noexec 0 0
    # glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for 
    # POSIX shared memory &#40;shm_open, shm_unlink&#41;.
    # &#40;tmpfs is a dynamically expandable/shrinkable ramdisk, and will
    #  use almost no memory if not populated with files&#41;
    shm                     /dev/shm        tmpfs           nodev,nosuid,noexec     0 0
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •