Find the answer to your Linux question:
Results 1 to 4 of 4
Trying to install GLib on Ubuntu by source.. ./configure runs fine, make runs fine, but i run intro this error on make install dan@ubuntu:~/glib-2.9.1$ make install make install-recursive make[1]: Entering ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2003
    Location
    Maryland
    Posts
    105

    GLib


    Trying to install GLib on Ubuntu by source..

    ./configure runs fine, make runs fine, but i run intro this error on make install

    dan@ubuntu:~/glib-2.9.1$ make install
    make install-recursive
    make[1]: Entering directory `/home/dan/glib-2.9.1'
    Making install in .
    make[2]: Entering directory `/home/dan/glib-2.9.1'
    make[3]: Entering directory `/home/dan/glib-2.9.1'
    /bin/sh ./mkinstalldirs /usr/local/bin
    /usr/bin/install -c glib-gettextize /usr/local/bin/glib-gettextize
    /usr/bin/install: cannot create regular file `/usr/local/bin/glib-gettextize': P
    ermission denied
    make[3]: *** [install-binSCRIPTS] Error 1
    make[3]: Leaving directory `/home/dan/glib-2.9.1'
    make[2]: *** [install-am] Error 2
    make[2]: Leaving directory `/home/dan/glib-2.9.1'
    make[1]: *** [install-recursive] Error 1
    make[1]: Leaving directory `/home/dan/glib-2.9.1'
    make: *** [install] Error 2


    Not too sure...

  2. #2
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    make install always needs to be run with root permissions.

    Since you're using Ubuntu:
    Code:
    sudo make install

  3. #3
    Linux Newbie
    Join Date
    Nov 2003
    Location
    Maryland
    Posts
    105
    Don't mind me, I'm mildly retarded :P

  4. #4
    Linux Newbie
    Join Date
    Nov 2003
    Location
    Maryland
    Posts
    105
    Ok, so I have Glib installed, newest version 2.9.1

    I try to compile GAIM 2.0 beta now, and I get this message when I ./configure...

    checking for GLIB - version >= 2.0.0...
    *** 'pkg-config --modversion glib-2.0' returned 2.9.1, but GLIB (2.8.3)
    *** was found! If pkg-config was correct, then it is best
    *** to remove the old version of GLib. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    *** to point to the correct configuration files
    no
    configure: error:
    *** GLib 2.0 is required to build Gaim; please make sure you have the GLib
    *** development headers installed. The latest version of GLib is
    *** always available at http://www.gtk.org/.
    dan@ubuntu:~/gaim-2.0.0beta1$

    I don't know where to go from here..sorry for asking silly questions

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •