Find the answer to your Linux question:
Results 1 to 5 of 5
i've managed to get my iPod working with gtkpod. It syncs. and writes correctly to the device, no problems. However, i can't get Amarok to transfer to to the iPod. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User PsypherPunk's Avatar
    Join Date
    Jan 2005
    Location
    Leeds, UK
    Posts
    257

    Question Amarok & iPod


    i've managed to get my iPod working with gtkpod. It syncs. and writes correctly to the device, no problems.

    However, i can't get Amarok to transfer to to the iPod. It can connect to the device, read the contents perfectly but when i attempt to transfer any queued music i just get:

    Code:
    Could not write to /mnt/ipod/iPod_Control/Music/F...
    If gtkpod can write i'm guessing it isn't a permissions issue. Is there anything further i'd need to do?
    Registered Linux User #379728

    SuSE 10.3 :: Athlon XP 3000+ :: AsRock K7VT4A Pro :: Nvidia Geforce 6600GT :: C-Media 8738

    www.psypherpunk.org.uk

  2. #2
    Just Joined!
    Join Date
    Dec 2005
    Posts
    2
    I was having the same problem. In my particular case, ivman was automouting the iPod at /media/ipod as user ivman and group plugdev. I am running Amarok as my local user and therefore could read, but not write(transfer). Mouting directly as root did not work either of course (unless I ran Amarok as root). The interim solution I came up with is to add an entry into fstab which will allow any user to mount the iPod. If you include 'user' in your fstab options line like such, any user can then mount it:
    /dev/sda2 /media/ipod vfat noauto,user 0 0
    I then bypass ivman and mount it as my local user and it transfers great

    Next step is to configure ivman/sudo properly so it mounts in a way that my local user doesn't have the extra step of mounting the ipod manually.

    Can you get gtkpod to transfer video properly? I am on Gentoo and using 0.94, it will not add .mpg files (file not recognized) and crashes when trying to add .m4a or .m4v files. I can force an install of 0.99.2, but gtkpod won't even start for me...libgpod seg faults on an error with hal.

    Fred Dirkse

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    2
    hi there!

    well, my ipod is mounting properly, user the correct owner (user) and group (root), but still cannot get amarok transfering files to the ipod.
    the strange thing is that it stopped working suddenly. it was working before and i made absolutely no update on amarok.
    i'm running suse 10.1. my next tryout should be then re-install amarok.

    cheers!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! TheBigBad's Avatar
    Join Date
    Nov 2006
    Location
    Iraq
    Posts
    4
    Youre not the only ones out there with problems doing this...Running FC6 and Amarok 1.4.4, I cant even get my g5 iPod to detect...The system detects it, and I can mount it, but Amarok doesnt see it...Any ideas?

  6. #5
    Just Joined!
    Join Date
    Nov 2006
    Posts
    2

    re-install

    good day!

    well, i have simply removed amarok and re-installed it. took an rpm from my SuSe 10.1 and the it worked. i'm having no problems since then.

    cheers!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •