Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18
Hellmasker, I am using the latest stable kernel 2.6 with Debian testing/unstable. As I really love this distro (am eager to try gentoo), I'd like to set this up first. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319

    Hellmasker,

    I am using the latest stable kernel 2.6 with Debian testing/unstable. As I really love this distro (am eager to try gentoo), I'd like to set this up first. As far as I can remember, I believe that all of the ACPI features were turned on excluding the experimental features. Last thing I can say is that the message on the screen (when turning off) stops at acpi_off.
    The best things in life are free.

  2. #12
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    ok, i found a new thign that might be wrong.

    do u have the acpi packages installed. I didnt even know there were such things but they show up in an rpm search.

    im just guessing here but it could work.

  3. #13
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Well, several thoughts here:

    1. Since apcid is a daemon, it'll be stopped before the acpi_off function is called.
    2. Installed acpid, didn't help.

    Would it be possible for you to list what you compiled under ACPI in the kernel?
    The best things in life are free.

  4. #14
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    yep, /me goes looking for kernel config file.

  5. #15
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    Code:
    #
    # ACPI Support
    #
    CONFIG_ACPI=y
    CONFIG_ACPI_BOOT=y
    CONFIG_ACPI_BUS=y
    CONFIG_ACPI_INTERPRETER=y
    CONFIG_ACPI_EC=y
    CONFIG_ACPI_POWER=y
    CONFIG_ACPI_PCI=y
    CONFIG_ACPI_SLEEP=y
    CONFIG_ACPI_SYSTEM=y
    CONFIG_ACPI_AC=m
    CONFIG_ACPI_BATTERY=m
    CONFIG_ACPI_BUTTON=m
    CONFIG_ACPI_FAN=m
    CONFIG_ACPI_PROCESSOR=m
    CONFIG_ACPI_THERMAL=m
    # CONFIG_ACPI_ASUS is not set
    # CONFIG_ACPI_TOSHIBA is not set
    # CONFIG_ACPI_DEBUG is not set
    CONFIG_ACPI_RELAXED_AML=y
    CONFIG_ACPI_INITRD=y
    although since ur having problems u might want to change debug to yes.

  6. #16
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    The things that looks like is missing from my kernel (2.6) is CONFIG_ACPI_INITRD and CONFIG_ACPI_SLEEP. I believe the latter is included only as an experimental feature. Which kernel source are you usiung? I think at this point, I'm going to have to try and turn the debug option to see if I can figure anything out. Do you know where I can find the debug messages after I recompile for ACPI?

    By the way, I really appreciate you helping me out here.
    The best things in life are free.

  7. #17
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Just found some interesting stuff out. After reading the README file for my Nvidia drivers at ftp://download.nvidia.com/XFree86/Li....0-5336/README
    (scroll all the way down), it looks like Nvidia cards don't have ACPI support. Could this be the reason why my 'power supply' doesn't shutdown when I run the shutdown command?
    The best things in life are free.

  8. #18
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319

    Updated Kernel Debugging Statments

    I've just enabled the debugging feature in my newest kernel. After doing a "grep -i acpi kern.log", this is the result.

    Mar 5 10:20:49 localhost kernel: BIOS-e820: 000000000fffc000 - 000000000ffff000 (ACPI data)
    Mar 5 10:20:49 localhost kernel: BIOS-e820: 000000000ffff000 - 0000000010000000 (ACPI NVS)
    Mar 5 10:20:49 localhost kernel: ACPI: RSDP (v000 ASUS ) @ 0x000f5e80
    Mar 5 10:20:49 localhost kernel: ACPI: RSDT (v001 ASUS A7S333 0x42302e31 MSFT 0x31313031) @ 0x0fffc000
    Mar 5 10:20:49 localhost kernel: ACPI: FADT (v001 ASUS A7S333 0x42302e31 MSFT 0x31313031) @ 0x0fffc0b2
    Mar 5 10:20:49 localhost kernel: ACPI: BOOT (v001 ASUS A7S333 0x42302e31 MSFT 0x31313031) @ 0x0fffc030
    Mar 5 10:20:49 localhost kernel: ACPI: MADT (v001 ASUS A7S333 0x42302e31 MSFT 0x31313031) @ 0x0fffc058
    Mar 5 10:20:49 localhost kernel: ACPI: DSDT (v001 ASUS A7S333 0x00001000 MSFT 0x0100000b) @ 0x00000000
    Mar 5 10:20:49 localhost kernel: ACPI: Local APIC address 0xfee00000
    Mar 5 10:20:49 localhost kernel: ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
    Mar 5 10:20:49 localhost kernel: ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
    Mar 5 10:20:49 localhost kernel: ACPI: Subsystem revision 20040116
    Mar 5 10:20:49 localhost kernel: tbxface-0117 [03] acpi_load_tables : ACPI Tables successfully acquired
    Mar 5 10:20:49 localhost kernel: ACPI Namespace successfully loaded at root c037e17c
    Mar 5 10:20:49 localhost kernel: ACPI: IRQ9 SCI: Level Trigger.
    Mar 5 10:20:49 localhost kernel: evxfevnt-0093 [04] acpi_enable : Transition to ACPI mode successful
    Mar 5 10:20:49 localhost kernel: ACPI: Interpreter enabled
    Mar 5 10:20:49 localhost kernel: ACPI: Using PIC for interrupt routing
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 10 *11 12 14 15)
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 *10 11 12 14 15)
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 *5 6 7 10 11 12 14 15)
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 10 11 12 14 15)
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 10 11 12 14 15)
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 10 11 12 14 15)
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 10 11 12 14 15)
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 7 10 11 12 14 15)
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Root Bridge [PCI0] (00:00)
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCI1._PRT]
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 9
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Interrupt Link [LNKH] enabled at IRQ 9
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 10
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 5
    Mar 5 10:20:49 localhost kernel: ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
    Mar 5 10:20:49 localhost kernel: PCI: Using ACPI for IRQ routing
    Mar 5 10:20:49 localhost kernel: PCI: if you experience problems, try using option 'pci=noacpi' or even 'acpi=off'
    Mar 5 10:20:49 localhost kernel: ACPI: Power Button (FF) [PWRF]
    Mar 5 10:20:49 localhost kernel: acpi_processor-2210 [29] acpi_processor_get_inf: Invalid PBLK length [5]
    Mar 5 10:20:49 localhost kernel: ACPI: Processor [CPU0] (supports C1)
    Can anyone tell me what's wrong with this? My PSU doesn't shutoff when I run this command.

    Also, this is the last message when the system is shutting down:
    Power Down
    acpi_power_off called
    hwsleep_0265 [24] acpi_enter_sleep_state: Entering sleep state [S5]
    The best things in life are free.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •