Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
Does anyone know what I need to tweak in ACPI for a desktop to shutoff by itself?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319

    ACPI


    Does anyone know what I need to tweak in ACPI for a desktop to shutoff by itself?
    The best things in life are free.

  2. #2
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    u could add the line acpi=off to the startup kernel parameters and let it use apm instead. (like i did)

    i assume it is just sitting there with "ok to power off" or "power down" on the screen. right?

    u do have a soft power button... and its set up in bios....?

  3. #3
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Yes, I do have it setup in the BIOS. I do not wish to use apm unless it's the last option.
    The best things in life are free.

  4. #4
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    in my experience if a bios does not like the linux ACPI implementation it just will not work. mine worked with the standard mdk9 kernel (which coudl well have had acpi disabled) but paniced on boot as soon as i tried ot use custom kernels.

  5. #5
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Does anyone have an idea what the problem is? Below are the information for my BIOS.

    Award Modular BIOS v6.0

    04/29/2002 - SiS745

    ASUS A7S333 ACPI BIOS rv 1003

    Hope this is enough.
    The best things in life are free.

  6. #6
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    thats the same board i put in my olds comp, and it shuts down fine using mdk 8.2 and 9.0.

    what distro are u using.

  7. #7
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Using Debian (testing/unstable) and running the newest stable kernel. That's very odd but it's good to have confirmation that you have gotten it to work. At least that gives me hope in solving this problem instead of going back to using APM.
    The best things in life are free.

  8. #8
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    have u flashed ur bios recently, im nto 100% on this but my olds is either running 1004 or 1006 bios. try downloading a new one from asus

  9. #9
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Yes, just installed 1006.

    Inside the BIOS, the option for soft off was under "PWR Button < 4 Secs"
    Is that what you have?
    The best things in life are free.

  10. #10
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    yep, that rings a bell, although i cant check right now coz they live about 400kms that way. /me points to my left

    can any other OS turn it off? older/newer version of whatever ur using? different distro?

    my last guess would be recompiling ur kernel and check that acpi features are all set up properly.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •