Find the answer to your Linux question:
Results 1 to 7 of 7
Hey all, I have a file/game/etc server hooked up to my tv. For a while i was running fedora 3 on it. Well recently i decided to switch to gentoo ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Location
    Pennsylvania
    Posts
    98

    mplayer full screen (sdl)


    Hey all,

    I have a file/game/etc server hooked up to my tv.
    For a while i was running fedora 3 on it.

    Well recently i decided to switch to gentoo as i like the os a bit more and decided i didn't want the 'bloat' that comes with fedora.

    Anyway, i have everything set up and working for the most part.

    The problem is that i like to use this system to watch movies and whatnot that are saved on my harddrive. On the fedora system i used:
    Code:
    mplayer -vo sdl filename
    In order to get a full screen movie.

    The video card i have is the original ATI All-In-Wonder Radeon (32M AGP) [no number associated with this card, but linux tends to detect it as a 7200]. So i start xorg using the vesa driver and everything seems hunky-dorey. I tried to watch a fullscreen movie and its all scrambled. The normal x11 driver
    Code:
    mplayer -vo x11 filename
    works fine.... i just can't get full screen under it (creates a black border around the video).
    To be honest i have no idea what sdl is, i just know thats how i got full screen movies before.

    I've tried moving to ati/radeon/fglrx drivers and get the same result.
    Using the gl driver
    Code:
    mplayer -vo gl filename
    i get fullscreen and its clear, but its jerky.
    glxgears gives an output of 250 fps.... which i don't think is good since my mobile nvidia card gets 2500 and it certainly isn't top of the line either.

    I don't really need a good card in this system as i don't play any games over the video quality of the snes. But having a clear fullscreen video sure would be helpful.

    Oh one more thing. I'm using icewm on this system and was using gnome on the fedora system. I can't imagine that would have anything to do with it, but who knows...

    I've emerged the latest version of libsdl and get the same result.
    Anyone have any ideas?

  2. #2
    Just Joined!
    Join Date
    Jan 2006
    Posts
    77
    the only thing i can think of is if you compiled mplayer with USE="sdl" (or something like that). also add SSE, SSE2, MMX, etc in that USE "thingy" as it might help when using gl.

  3. #3
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    two things: first try -vo gl2 and -ao alsa

    With gentoo you need to compile mplayer with architecture specific flags to get optimal performance. The best way to see this is to to:

    Code:
    emerge -va mplayer
    check out all the USE flags that it shows for processor stuff

    then

    Code:
    cat /proc/cpuinfo
    check out the cpuflags your processor has and add them to make.conf
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  4. #4
    Just Joined!
    Join Date
    May 2004
    Location
    Pennsylvania
    Posts
    98

    Smile

    Thanks for the help guys.
    Still couldn't get it to work with sdl, gl, or gl2 even after adding as many USE flags as seemed logical.

    I have however found that
    Code:
    mplayer -zoom -fs filename
    seems to work fairly well.
    iirc that command didn't work too well on my older system, hence why i used sdl. But if its working now that all i care about.

    Once again thanks for the help, still not sure what the problem is, but i don't know that my gl is set up properly, as when i do a glxinfo, the vendor string is mesa, not ati as i would expect. I've done
    Code:
    eselect opengl set ati
    and it says ok with no errors....

    at this point i don't care though until i find something i can't do... as i said this server is mainly set up for file/web/etc serving and i only occasionally boot to X to watch movies or play something on mame/nes/etc

  5. #5
    Banned
    Join Date
    Aug 2004
    Posts
    15
    you may also need to rebuild X with just the server for your video card enabled

  6. #6
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Just a quick thing slightly off subject. You runing on your TV - Are you using MythTV or any other PVR? I'm about to set up a box with it on it.

  7. #7
    Just Joined!
    Join Date
    Oct 2005
    Posts
    2
    You need to use the xv driver:

    mplayer -vo xv -fs filename

    or in gui go to preferences and on video tab select xv

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •