Find the answer to your Linux question:
Results 1 to 5 of 5
I use Fluxbox as my default WM, but I haven't solved this yet: KDE and Gnome (etc.) allow to switch to virtual console by pressing ctrl + alt + F1, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Feb 2006
    Location
    KP22
    Posts
    106

    X, consoles and Fluxbox


    I use Fluxbox as my default WM, but I haven't solved this yet: KDE and Gnome (etc.) allow to switch to virtual console by pressing ctrl + alt + F1, F2, F3 and so on. Fluxbox grabs every keypress due to its internal shortcut key detection, and so this key combination can't be used by normal. So, have you any suggestions? If there is a program which can switch to console I can add it to my key-shortcut file.

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    I used to use Fluxbox all the time, and I don't remember having such a problem. What are your current shortcuts?

  3. #3
    Linux Newbie
    Join Date
    Feb 2006
    Location
    KP22
    Posts
    106
    Code:
    Mod1 Tab :NextWindow
    Mod1 Shift Tab :PrevWindow
    Mod1 F4 :Close
    Mod1 m :Minimize
    Mod4 F1 :Workspace 1
    Mod4 F2 :Workspace 2
    Mod4 F3 :Workspace 3
    Mod4 F4 :Workspace 4
    
    Control Q :ExecCommand xscreensaver-command -lock
    Control Mod1 X :ExecCommand xkill
    Mod4 r :ExecCommand fbrun -font 10x20 -fg grey -bg black -title run
    Mod4 a :ExecCommand aterm -name aterm
    Mod4 s :ExecCommand import -window root png:screen.png
    
    Mod4 z :ExecCommand xmms -r
    Mod4 x :ExecCommand xmms -f
    Mod4 c :ExecCommand xmms -p
    Mod4 v :ExecCommand xmms -s
    Mod4 b :ExecCommand xmms -u
    Mod4 n :ExecCommand xmms -s
    That is my ~/.fluxbox/keys -file, do you need more information?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1
    Here's a simple solution: change your key defs to something else. I commented out mine since I don't use the extra workspaces.

    Code:
    Mod1 Tab :NextWindow
    Mod1 Shift Tab :PrevWindow
    #Mod1 F1 :Workspace 1
    #Mod1 F2 :Workspace 2
    #Mod1 F3 :Workspace 3
    etc...
    Now I can switch to the consoles without fluxbox catching my keypresses. If you set up a different key mapping, you should be able to work around the problem, too, while being able to switch amongst your workspaces.

  6. #5
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    Quote Originally Posted by lakerdonald
    I used to use Fluxbox all the time, and I don't remember having such a problem. What are your current shortcuts?
    Same here... maybe check for something in /etc/X11/xorg.conf for the "DontVTSwitch" option.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •