Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Need help with PROFTPD install

    Mandrake Linux 9.1
    Webmin Version 1.070

    Trying to install this package:

    Getting this error:
    Install failed :

    error: failed dependencies: is needed by proftpd-1.2.9-1.9 is needed by proftpd-1.2.9-1.9
    perl( is needed by proftpd-1.2.9-1.9
    perl(strict) is needed by proftpd-1.2.9-1.9

    You may attempt to install again by going back to the previous page and selecting different install options.

    Otherwise, click here to delete the temporary package file in order to save disk space.
    The option to Ignore Dependencies is turned OFF.

    Up until yesterday the server was running just peachy on Mandrake 9.0 but some moron (me) decided to run Apache and proftpd updates... unfortunately I ran the Mandrake 9.1 instead of 9.0 updates and nuked the proftpd software. After hours of trying to get it to work, I just decided to upgrade to 9.1 hoping for a fix. When accessing the proftpd webmin module now it just says proftpd isn't installed, which is better than what I was getting before. So I decided to run the package installer and start clean with proftpd... and thats where the error comes into play.

    Any advice? Thanks.

  2. #2
    Linux Engineer
    Join Date
    Apr 2003
    Thats a little wierd check in your /lib directory if thoose libs exist, Thoose are not included by any specific software package but are a core in the installation i think..


  3. #3
    The files exist in /usr/lib and I also just copied them to /lib to be sure. Im still getting the same error... so it leaves me wondering if perhaps the package is looking for them at another place?

    Im more or less a Linux newb so I dont even understand what it is that these files do, or how they work. All I know is that I need my FTP server back up ASAP, and the proftpd package wont install.

  4. $spacer_open
  5. #4
    Linux Engineer
    Join Date
    Dec 2002
    New Zealand
    search google or and find out what packages provide these files, then reinstall them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts