I'll be brief.
I just switched from JamD to Fedora, and I copied my old Firebird directory over from the previous install. (It was a manual install version)

I ran Firebird a few times them ran Mozilla, all was well. I did an update of Mozilla using Fedora's up2date and it froze. I then re-opened up2date and it showed that Mozilla had been updated 1.4.x to 1.4x something. When I tried to run Mozilla it gives me the following error.
"Error launching browser window:TypeError:Components.Classes[@mozilla.org/appshell /component/browser/instance;1] has no properties.

I checked the Mozilla forums and found nothing, I was surprised. I then checked the usenet. A few mentioned that you should uninstall the mozilla package and then remove any .mozilla folders in the home directory. Reinstal mozilla and all should be fine. I did that and Mozilla worked!

The problem is that I used it for a while then installed the flash plugin. I closed Mozilla and when I went to re-open it. Bam! I got the same error.
What could be causing this? Removing the .mozilla directory everytime this happens is not a solution.

Thanks in advance!