Find the answer to your Linux question:
Results 1 to 3 of 3
I have recently installed Ubuntu Linux 5.10 on my computer. I am now trying to install some more applications. After overcoming a few errors by research on the net, such ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    2

    Application installation... HELP!


    I have recently installed Ubuntu Linux 5.10 on my computer. I am now trying to install some more applications. After overcoming a few errors by research on the net, such as gcc not being installed (WHY WOULD IT NOT BE INSTALLED IN THE FIRST PLACE???), and having to rename my directories to names without spaces in them leading to where the .tar.gz packages are located. I have come to a stop. I got gcc installed, and am trying to install the application X MultiMedia System (XMMS) and it now says I do not have glib, when trying to install glib (entering the ./configure command in terminal), after lots of other lines, it says

    "You must either have gettext support in your C library or use the GNU gettext library"

    , after looking up gettext it says its a program to support other languages etc. no idea why that is required, nonetheless, I downloaded the latest version of gettext: 0.14.5, ran the ./configure command, worked, ran make, worked, ran make install, and it says:

    "mkdir: cannot create directory `usr/local/share/aclocal': Permission Denied"

    I have been researching and for this error people say to enter su, then the root password, then make install... I am in the root user account, and it says:

    "su: Authentication failure
    Sorry."

    I created another account and tried again and it still says that when I enter the password to the root account. I have also tried installing an earlier version of gettext: 0.14.1 and I get exactly the same problem. I also tried creating the folder aclocal just by dragging it into the usr/local/share/ directory, and it still says I do not have permission... how can I not have permission if I am the root user?



    Why is it that installing a program in linux must be done through compiling the source code anyway? I am really confused, been trying different things for hours, why can't you just install programs from a setup file like in windows? Anyway, I would be very greatful if you were to shed some light on the subject...

  2. #2
    Just Joined!
    Join Date
    Apr 2006
    Posts
    2
    mmm... been 5 days since I posted this thread... I noticed when I was installing linux again that the account that you make is not the root account... if I haven't done anything in relation to the root account then how do I access it?

    Still waiting... someone please help.

  3. #3
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Alrighty.

    First off, you need to understand that Ubuntu does differ a little bit in its approach to security. One aspect of this is that access to root is disabled by default. If you need to access root on the commandline, you are encouraged to use 'sudo', which temporarily grants you access to root commands (but still requires a password). You also cannot shut down the X Server and keep the computer running.

    As far as gcc not being installed by default, this is a common thing in many binary-based distros.


    Anywho, to install packages in Ubuntu, you use Synaptic, which is a GUI frontend for apt-get. Recall that Ubuntu is based on Debian, and so also uses apt-get.

    Anyway, run Synaptic and install the package you want. Synaptic will automatically handle all dependencies for you.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •