Find the answer to your Linux question:
Results 1 to 4 of 4
Strangely enough, i am getting a mkdir error when I run a rsync command. It states that there is a permission of denial when it tries to make the directory, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! jobygjoseph's Avatar
    Join Date
    Apr 2006
    Posts
    1

    mkdir failed: permission denied


    Strangely enough, i am getting a mkdir error when I run a rsync command. It states that there is a permission of denial when it tries to make the directory, but the directory is already there. Both the source directory and the target directories are open to the public for testing (777). Also both user and groups are the same for both directoreis. I just don't get it.

    I have already searched the forums for this but none like this so far. Maybe I missed it.

    Here is the error:
    mkdir "/path/to/target/dir" failed: Permission denied rsync error: error in file IO (code 11) at main.c(346)
    rsync: connection unexpectedly closed (8 bytes received so far) [sender] rsync error: error in rsync protocol data stream (code 12) at io.c(434)


    running rsync (version 2.6.6 protocol version 29) on fedora2
    rsync from one server to another

  2. #2
    Linux User DThor's Avatar
    Join Date
    Jan 2006
    Location
    Ca..na...daaa....
    Posts
    319
    Just double checking - but what form are you calling it in? You're ensuring one end(source or destination) is local? Are you running either over an NFS mount?

    DT

  3. #3
    Just Joined!
    Join Date
    Apr 2007
    Location
    Arouca, Trinidad
    Posts
    4

    Unhappy

    i am also receiving the same error [on local drives across two servers]; if it is NFS, will that cause a problem?

    does anyone have a solution for this yet?

    any help would be appreciated.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2007
    Posts
    1
    You might have a problem by setting an absolute path for your remote server. what you are doing is asking rysnc to create a directory directly under root - that would give you a "permission denied" error message.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •