Find the answer to your Linux question:
Results 1 to 5 of 5
I get the below error message when trying to play video files in Mplayer. What does the message mean? Is it anything my system lacks? Code: VDec: vo config request ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    14

    Mplayer: FATAL: Could not initialize video filters (-vf) or video output (-vo)


    I get the below error message when trying to play video files in Mplayer. What does the message mean? Is it anything my system lacks?

    Code:
    VDec: vo config request - 720 x 544 (preferred csp: Planar YV12)
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    The selected video_out device is incompatible with this codec.
    
    FATAL: Could not initialize video filters (-vf) or video output (-vo).
    
    Can't restore text mode: Invalid argument
    Complete output was:

    Code:
    MPlayer 1.0pre7try2-3.4.5 (C) 2000-2005 MPlayer Team
    CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Stepping: 10)
    Detected cache-line size is 32 bytes
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
    Compiled for x86 CPU with extensions: MMX MMX2 SSE
    
    
    Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
    Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
    Playing Within Temptation - Running Up That Hill.avi.
    AVI file format detected.
    VIDEO:  [DX50]  720x544  24bpp  24.998 fps  3079.3 kbps (375.9 kbyte/s)
    ==========================================================================
    Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
    AUDIO: 44100 Hz, 2 ch, s16le, 224.0 kbit/15.87% (ratio: 28000->176400)
    Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
    ==========================================================================
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
    ==========================================================================
    Checking audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
    AF_pre: 44100Hz/2ch/s16le
    AO: [oss] 44100Hz 2ch s16le (2 bps)
    Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
    Starting playback...
    VDec: vo config request - 720 x 544 (preferred csp: Planar YV12)
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    The selected video_out device is incompatible with this codec.
    
    FATAL: Could not initialize video filters (-vf) or video output (-vo).
    
    Can't restore text mode: Invalid argument
    
    Exiting... (End of file)
    I'm using Ubuntu 'Breezy Badger' and kernel version 2.6.12-9-386.

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Do you have a MPlayer config file?

    Should be in /home/your_user/.mplayer/config.

    For example, see here:
    http://www.ubuntuguide.org/sample/mplayer.conf_mplayer

    Or just try to play your movie with very conservative options:
    Code:
    mplayer -vo x11 -zoom your_movie.avi
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    14
    Do you have a MPlayer config file?

    Should be in /home/your_user/.mplayer/config.

    For example, see here:
    http://www.ubuntuguide.org/sample/mplayer.conf_mplayer
    I added everything in the linked config file to my config file, but it didn't seem to have any effect, that is if I wrote "vo=satan" in config, and it still gave the same output as above. Do I have to initialize this config-file somehow?

    Or just try to play your movie with very conservative options:
    Code:
    mplayer -vo x11 -zoom your_movie.avi
    I've tried this several times, but x11 does not exist as a video output in mplayer:

    Code:
    Error opening/initializing the selected video_out (-vo) device.
    How do I add it? I've tried to make a symlink to the apparent X11-folder in Ubuntu as described here (search x11), but it didn't help.

    Thank you for trying to help me

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by miceagol
    I've tried this several times, but x11 does not exist as a video output in mplayer:
    Sure it does. Unless you compiled it yourself and disabled the x11 extension. Try
    Code:
    mplayer -vo help
    for a complete list of video output.

    Quote Originally Posted by miceagol
    How do I add it? I've tried to make a symlink to the apparent X11-folder in Ubuntu as described here (search x11), but it didn't help.
    Wow I never had to do that on Ubuntu. Did you install MPlayer from the Ubuntu's multiverse repository? Like that:
    http://easylinux.info/wiki/Ubuntu#Ho...ozilla_Firefox

    Also, what is your video card? Did you install the drivers for it?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #5
    Just Joined!
    Join Date
    Jun 2006
    Posts
    14
    Quote Originally Posted by antidrugue
    Sure it does. Unless you compiled it yourself and disabled the x11 extension.
    When I first installed it, I installed it from source. When it didn't work, I tried installing the i386-package from here. I did everything once again with the i586-version instead, and the i386-version was removed in the process. The output was:

    Code:
    root@laptop:/usr/lib# apt-get install mplayer-586
    Reading package lists... Done
    Building dependency tree... Done
    The following extra packages will be installed:
      liblame0
    Suggested packages:
      w32codecs libdvdcss mplayer-doc
    The following packages will be REMOVED:
      mplayer-386
    The following NEW packages will be installed:
      liblame0 mplayer-586
    0 upgraded, 2 newly installed, 1 to remove and 1 not upgraded.
    Need to get 3910kB of archives.
    After unpacking 176kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://no.archive.ubuntu.com breezy/multiverse liblame0 3.96.1-1 [151kB]
    Get:2 http://no.archive.ubuntu.com breezy/multiverse mplayer-586 1:1.0-pre7cvs20         050716-0.1ubuntu9 [3759kB]
    Fetched 3910kB in 31s (124kB/s)
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LANGUAGE = "nb_NO:nb:no_NO:no:en_GB:en",
            LC_ALL = (unset),
            LANG = "nb_NO.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    
    Preconfiguring packages ...
    dpkg: mplayer-386: dependency problems, but removing anyway as you request:
     mplayer-fonts depends on mplayer; however:
      Package mplayer is not installed.
      Package mplayer-386 which provides mplayer is to be removed.
    (Reading database ... 82236 files and directories currently installed.)
    Removing mplayer-386 ...
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LANGUAGE = "nb_NO:nb:no_NO:no:en_GB:en",
            LC_ALL = (unset),
            LANG = "nb_NO.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    Selecting previously deselected package liblame0.
    (Reading database ... 82141 files and directories currently installed.)
    Unpacking liblame0 (from .../liblame0_3.96.1-1_i386.deb) ...
    Selecting previously deselected package mplayer-586.
    Unpacking mplayer-586 (from .../mplayer-586_1%3a1.0-pre7cvs20050716-0.1ubuntu9_i386.deb) ...
    Setting up liblame0 (3.96.1-1) ...
    
    Setting up mplayer-586 (1.0-pre7cvs20050716-0.1ubuntu9) ...
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LANGUAGE = "nb_NO:nb:no_NO:no:en_GB:en",
            LC_ALL = (unset),
            LANG = "nb_NO.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    Quote Originally Posted by antidrugue
    Try
    Code:
    mplayer -vo help
    for a complete list of video output.
    Yep, tried every option there, but not any of them works:
    Code:
    michaeka@laptop:~/filer/nedlast/MPlayer-1.0pre7try2$ mplayer -vo help
    MPlayer 1.0pre7try2-3.4.5 (C) 2000-2005 MPlayer Team
    Good morning, Blindern
    CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Stepping: 10)
    Detected cache-line size is 32 bytes
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
    Compiled for x86 CPU with extensions: MMX MMX2 SSE
    
    
    Warning unknown option skin at line 52
    Available video output drivers:
            fbdev   Framebuffer Device
            fbdev2  Framebuffer Device
            vesa    VESA VBE 2.0 video output
            cvidix  console VIDIX
            null    Null video output
            mpegpes Mpeg-PES to DVB card
            yuv4mpeg        yuv4mpeg output for mjpegtools
            tga     Targa output
            pnm     PPM/PGM/PGMYUV file
            md5sum  md5sum of each frame
    Quote Originally Posted by antidrugue
    Wow I never had to do that on Ubuntu. Did you install MPlayer from the Ubuntu's multiverse repository? Like that:
    http://easylinux.info/wiki/Ubuntu#Ho...ozilla_Firefox
    Did as on the website, but with the i586-package.

    Quote Originally Posted by antidrugue
    Also, what is your video card? Did you install the drivers for it?
    I haven't installed the drivers myself, but it seems Ubuntu did it for me
    The device manager says ATI Rage Mobility P/M AGP 2x, and lspci gives:
    Code:
    0000:01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility P/M A                               GP 2x (rev 64)        GP 2x (rev 64)
    I beleive that the error here may be that mplayer lacks the proper path to the xv video output filter. It looks like it's present when i run xvinfo:
    Code:
    michaeka@laptop:~/filmer$ xvinfo
    X-Video Extension version 2.2
    screen #0
      Adaptor #0: "ATI Mach64 Back-end Overlay Scaler"
        number of ports: 1
        port base: 61
        operations supported: PutImage
        supported visuals:
          depth 24, visualID 0x23
          depth 24, visualID 0x24
          depth 24, visualID 0x25
          depth 24, visualID 0x26
          depth 24, visualID 0x27
          depth 24, visualID 0x28
          depth 24, visualID 0x29
          depth 24, visualID 0x2a
        number of attributes: 12
          "XV_SATURATION" (range -1000 to 1000)
                  client settable attribute
                  client gettable attribute (current value is 391)
          "XV_BRIGHTNESS" (range -1000 to 1000)
                  client settable attribute
                  client gettable attribute (current value is 15)
          "XV_COLOUR" (range -1000 to 1000)
                  client settable attribute
                  client gettable attribute (current value is 391)
          "XV_COLOR" (range -1000 to 1000)
                  client settable attribute
                  client gettable attribute (current value is 391)
          "XV_AUTOPAINT_COLOURKEY" (range 0 to 1)
                  client settable attribute
                  client gettable attribute (current value is 1)
          "XV_AUTOPAINT_COLORKEY" (range 0 to 1)
                  client settable attribute
                  client gettable attribute (current value is 1)
          "XV_COLOURKEY" (range 0 to 16777215)
                  client settable attribute
                  client gettable attribute (current value is 197121)
          "XV_COLORKEY" (range 0 to 16777215)
                  client settable attribute
                  client gettable attribute (current value is 197121)
          "XV_COLOURKEY_MASK" (range 0 to 16777215)
                  client settable attribute
                  client gettable attribute (current value is 16777215)
          "XV_COLORKEY_MASK" (range 0 to 16777215)
                  client settable attribute
                  client gettable attribute (current value is 16777215)
          "XV_SET_DEFAULTS" (range 0 to 0)
                  client settable attribute
          "XV_DOUBLE_BUFFER" (range 0 to 1)
                  client settable attribute
                  client gettable attribute (current value is 0)
        maximum XvImage size: 720 x 2048
        Number of image formats: 4
          id: 0x32595559 (YUY2)
            guid: 59555932-0000-0010-8000-00aa00389b71
            bits per pixel: 16
            number of planes: 1
            type: YUV (packed)
          id: 0x59565955 (UYVY)
            guid: 55595659-0000-0010-8000-00aa00389b71
            bits per pixel: 16
            number of planes: 1
            type: YUV (packed)
          id: 0x32315659 (YV12)
            guid: 59563132-0000-0010-8000-00aa00389b71
            bits per pixel: 12
            number of planes: 3
            type: YUV (planar)
          id: 0x30323449 (I420)
            guid: 49343230-0000-0010-8000-00aa00389b71
            bits per pixel: 12
            number of planes: 3
            type: YUV (planar)
    Another possible hint to this being the error is that I have no problems playing videos in VLC, with the same filter I beleive. Where is the xv filter located, and how do I configure mplayer to find it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •