Find the answer to your Linux question:
Results 1 to 3 of 3
I'm sure some variation of this question exists in some form or another. I've been looking everywhere, and I just can't seem to get this problem resolved. I'm still pretty ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    2

    Cannot connect to CVS server (connection refused)


    I'm sure some variation of this question exists in some form or another. I've been looking everywhere, and I just can't seem to get this problem resolved.

    I'm still pretty new to linux.

    Anyway, I have installed the mandrake 10 distribution and have setup and installed cvs running on port 2401. The cvs server works great from my lan. I can access from both my linux machine and my windows laptop using the private static ip address assigned to my linux machine.

    However, when I attempt to access the server using the wan ip, it says "connection refused." I have port 2401 forwarded on my router and "canyouseeme.org" claims to see the service.

    I really believe it to be some setting in the OS, but I can't figure it out for the life of me.

    I was playing around a little bit more with my router configuration and I figured I'd try setting the router to dmz again.

    Interestly enough, this time when I tried to connect, it gave me a "timeout" error instead of "refused."

    I'm thinking that maybe my problem is two fold. Perhaps, the port forwarding is not working as it should be in addition to a software firewall blocking my connection attempts.

    To the best of my knowledge, I have disabled the firewall and set the default security setting to "poor" (not sure if that makes any difference, but I'll try anything at this point). I also temporarily disabled iptables (again, to the best of my knowledge this was done correctly). When I ran "iptables -L" as root, only the 3 headings came up.

    Is there possibly something I have done wrong? Or some other firewall I have overlooked? Does cvs need to be configured differently if external connections are necessary?

  2. #2
    Just Joined!
    Join Date
    Jun 2006
    Posts
    2

    **bump**

    I'll give it one last try.

  3. #3
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,914
    Can you not configure this kind of access better using ssh? I've only ever used cvs over the internet in this secure way (and then only from a windows client).
    Linux user #126863 - see http://linuxcounter.net/

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •