Find the answer to your Linux question:
Results 1 to 3 of 3
Im not sure if there is some sort of lockfile that needs resetting for rpm, but i cant do anything with rpm as it just hangs without clocking up any ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2004
    Posts
    14

    rpm is hanging on simple requests


    Im not sure if there is some sort of lockfile that needs resetting for rpm, but i cant do anything with rpm as it just hangs without clocking up any CPU time (almost as if it waits for a lock file). This applies to anything rpm related, even querying a file. Im not sure whats wrong. I have tried rebuilding the database, but of course that hangs. Anyone got any ideas?

  2. #2
    Linux Enthusiast scientica's Avatar
    Join Date
    Sep 2003
    Location
    South- or "Mid-" Sweden
    Posts
    742
    Sounds like the rpm database has 'hung', but I'm afraid I don't remember how I solved it, I zaped some files and rebuild the db, I'll see if I can find the google result that solved it for me.

    [EDIT]I think I did something like this:
    Code:
    rm -rf /var/lib/rpm/__db* && rpm --rebuild
    [/EDIT]
    Regards Scienitca (registered user #335819 - http://counter.li.org )
    --
    A master is nothing more than a student who knows something of which he can teach to other students.

  3. #3
    Just Joined!
    Join Date
    Feb 2004
    Posts
    14
    thankyou very much. That worked a treat. I thought it was something to do with files hindering rpm. Will remember to remove those __db.* files in the future. Thanks again.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •