Hi all - newbie to linux - running RH9 on a AMD K6 150 mhz/ 64 mb - not the fastest system...!
Trying to set up a kiosk mozilla installation I found on freshmeat and having some problems.
I can install the kiosk mod and when I click on my mozilla icon, it fires up the kiosk browser as expected for both root and my user - user1.
Part of the instructions suggest changing the inittab so that it autologs on and runs the kiosk automatically.
So, I have added the line:
k:4:respawn:/home/user1/kiosk/kiosk.sh to inittab for testing. If I telinit 4, I get a respawning too fast error so I have tried to look at the app.
Kiosk.sh contains the following:

#!/bin/sh
PATH=/bin:/usr/bin:/usr/X11R6/bin
ulimit -v 65536
exec xinit /home/user1/kiosk/kiosk-session --$xargs >/tmp/.xsession-errors 2>&1

so, if i then try and run this script, nothing really happens except the screen goes black and then returns to the command line (logged in as root at command line not GUI).
So I then look at kiosk-session which contains:

#!/bin/sh
#simply logs in as "kiosk" and runs that user's .xsession. This assumes it #was launched by root, so that "su kiosk" will not #prompt for a password.

exec su --login --command /home/user1/kiosk/.xsession kiosk

Now I've changed last word from kiosk to user1 yet the script kiosk.sh above will still will not run.
I have then tried to run kiosk-session and this returns an error:
Fatal server error
PAM authentication failed, cannot start X server. Perhaps you do not have ownership?


So now I go and look at .xsession which has a load of remmed lines but the important (in my inexperienced view) ones are:
export PATH=$PATH:/bin:/usr/bin
xscreensaver -no-splash&
while true ; do
/usr/bin/mozilla -chrome chrome://kiosk/content
done

So I then tried running the mozilla command but it didn't work from a command line so I started X and ran from there in a terminal and also from "run program" . Both occasions they fired up the original mozilla browser. So I then checked my toolbar shortcut properties and noticed that it pointed to a different location, so I have changed the line to:
/usr/local/mozilla/mozilla
However, when I run kiosk.sh, still nothing happens excpet a black screen and then return to command line.
When I run kiosk-session, I get the PAM auth error as above except with these lines:
xinit: no such file or directory (errno 2): unable to connect to X server
xinit: No such process (errno 3): Server error

When I run .xsession I then get a load of gtk warnings - cannot open display plus some other text which I missed.

Now, when I telinit 4, it appears to almost start X ( I get the X on the screen but then flashes back to the command line and back again/ forward again).
I've run out ideas as to what to do now - does anyone have any ideas?
There was an alternative to this autostart yet I cannot get that working either. I may post that too if I don't get anywhere with this method.
thanks