Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 27 of 27
Hi jenny_psion, First, open a terminal and change directory to the location where you have downloaded the compressed file and extract the xemacs-21.4.19.tar.gz file by running the following command : ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Linux User
    Join Date
    Jun 2006
    Posts
    311

    Hi jenny_psion,
    First, open a terminal and change directory to the location where you have downloaded the compressed file and extract the xemacs-21.4.19.tar.gz file by running the following command : -
    $ tar -zxvf xemacs-21.4.19.tar.gz
    Then change directory to xemacs-21.4.19 : -
    $ cd xemacs-21.4.19
    Now, become superuser by running su and enter the root password when asked : -
    $ su
    password:enter_password
    #
    Now first run configure and then compile by : -
    # ./configure
    # make
    Once it is configured and compiled without any issues, install it by running : -
    # make install
    After successful installation, you can run the following command to clean up the files that were generated during the installation : -
    # make clean
    That is it and you should be able to run XEmacs.

    With Regards,
    Thinker

  2. #22
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13
    Hello,

    Thanks for this!
    I think that I am getting an error when typing ./configure.
    This is the last bit of the output I get:
    Code:
    checking for dld_init in -ldld... no
    configure: warning: Module support cannot be provided.
    
    *** PANIC *** configure forgot how to build working executables!
    
    *** This is most commonly due to an unforeseen environment, causing
    *** configure to incorrectly compute the sequence of libraries to link.
    *** Please examine the tail of config.log for runtime errors.
    *** Pay special attention to the -l flags, and perhaps -I and -L.
    *** Often adding or removing explicit options in the configure
    *** invocation can work around this kind of problem.  If so, please
    *** report it as a bug to xemacs-beta@xemacs.org.
    ***
    *** Other possible causes are inability to write to the file system
    *** (bogus permissions or disk full) or a misconfiguration of the dynamic
    *** linker.  On Linux, check /etc/ld.conf and rerun ldconfig if
    *** necessary.  On other systems, try telling configure where to find
    *** the shared libraries using the --site-runtime-libraries option.
    ***
    *** Another way to shoot yourself in the foot is to specify
    *** --with-FEATURE when FEATURE is not actually installed on your
    *** system.  Don't do that.
    Then, when I type "make", I get this:

    Code:
    jen@portableTyke:~/xemacs-21.4.19$ sudo make
    make: *** No targets specified and no makefile found.  Stop.
    Thanks,
    Jenny

  3. #23
    Linux User
    Join Date
    Jun 2006
    Posts
    311
    Hi jenny_psion,
    Try running ldconfig after becoming superuser and start installation of XEmacs after that : -
    # /sbin/ldconfig
    With Regards,
    Thinker

  4. #24
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13
    Hello,

    Even if I do this, I get the same error after running ./configure.

    Thanks,
    Jenny

  5. #25
    Linux User
    Join Date
    Jun 2006
    Posts
    311
    Hi jenny_psion,
    Try configuring with the option --with-modules=no, i.e.,
    # ./configure --with-modules=no
    With Regards,
    Thinker

  6. #26
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13
    hi,

    strange... i still get the same error.

    jenny

  7. #27
    Linux User
    Join Date
    Jun 2006
    Posts
    311
    Hi jenny_psion,
    Can you post the contents of config.log file that is generated after you run configure?

    With Regards,
    Thinker

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •